メインコンテンツにスキップ

Model A1418 / Mid 2014 / 1.4, 2.7 & 2.9 GHz Core i5 もしくは3.1 GHz Core i7 プロセッサ

50回答 すべてを表示

Display backlight not working

I dissembled my device to replace a HDD with a new SSD. When I put everything back, all the components worked flawlessly. However, when it go to sleep mode, the backlight not turn back on, I still can see the content on display if I shine the flashlight on it. Every time I want to get backlight back on, I had to unplug the device and leave it there for a while, then plug it back and turn on.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

3 件のコメント:

@hellomacos - You might be able to help this person!

さんによる

@beanman56

Thanks for tagging me in:-)

さんによる

Hi

It might be worth disassembling the device again and examining the board for anything that looks blown(burned discoloured)

I would also try a SMC Reset

https://support.apple.com/en-gb/HT201295

Thanks:-)

さんによる

コメントを追加

1 件の回答

Based on the information provided, it is possible that the issue may be caused by a malfunctioning backlight circuit or a loose connection between the display and backlight components.

To fix this issue, you could try the following steps:

  1. Check the connections between the display and backlight components to make sure they are properly seated and not loose.
  2. Update the display and graphics drivers on your device.
  3. Check the power settings and ensure that the display is set to turn on after waking from sleep mode.
  4. Reset the device's PRAM (Parameter Random Access Memory) and NVRAM (Non-Volatile Random Access Memory).
  5. If the issue persists, it may be necessary to replace the backlight or other components.

It is important to note that opening and attempting to repair electronic devices can be dangerous and may void any warranties. If you are unsure about any of the steps or do not have the necessary technical skills, it may be best to seek professional help from an authorized repair service or contact the manufacturer for assistance.

このアンサーは役に立ちましたか?

スコア 0

1件のコメント:

I checked them carefully and several times. All the sockets are good, no exploded components on the mainboard. I have one big concern about the PRAM battery, does a weak CMOS battery cause this issue?

さんによる

コメントを追加

回答を追加する

Khôi Trần さん、ありがとうございました!
統計データ:

過去 24時間: 0

過去 7 日: 3

過去 30 日: 5

今までの合計 68