メインコンテンツにスキップ

Model A1001 or A1025 / 667, 800, 867, or 1.0 GHz G4 processor

68の回答 すべて表示

Screen No Longer Viewable. Lines Ghost Images

PB starts up, but I cannot see what's what on the screen. It's all jumbled, multiple lines, can sorta make out 3 ghost images of the desktop.

Is this a hinge connector, the lcd screen, or the logic board??

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

iPhoneのバッテリーキット

Only $29.99

Buy Now

iPhoneのバッテリーキット

Only $29.99

Buy Now

3回答

選択されたソリューション

The video cable is routed around the left side hinge. With heavy use this will cause the cable to weaken. Many owners have reported display problems such as random lines or a jumbled screen. A few have replaced just the video cable to successfully resolve this problem.

Here's the part: G4 Titanium Display Data Cable

Ifixit is out of stock but adds this warning:

Works in all 15" Titanium PowerBooks regardless of color of existing cable. Responsible for transmitting data from the logic board to the display. Installation will damage your computer's display if performed improperly. Specialized equipment is required for installation.

I don't really agree with this. Sure it's not easy but if you're here, you're probably good at fixing things. Care should be taken. The specialized tools needed are: 4mm Nut Driver, T6 and T8 Torx screw drivers and most likely a spudger.

この回答は役に立ちましたか?

スコア 1

コメント:

Hopefully this makes sense. It happened once before briefly, then worked fine. Now it is always jumbled. I'll check out the cable. Thanks for the replies. I asked a question on the other post with the MBP.

による

Wow, do I need to completely disassemble the PB as in the directions for installing the display in order to get to this cable???? I'm game, but wanted to double-check first, since there are no instructions for the cable you linked.

による

I just thought of something. I connected it to an external monitor, and the problem is on both screens. Can this still be the cable, or does that mean the logic board for sure?

による

コメントを追加

I just resolved this problem with mine today by replacing the display data cable. I had to follow the 17 pages of directions here, then a few more pages from this PDF: http://www.PowerBookmedic.com/xcart1/fil...

The worst part of this is that you have to disassemble the LCD housing (the lid) and it's glued together with epoxy. Mine didn't turn out TOO bad but it's definitely battle scarred now. It did work, by the way, but it took me over 7 hours to do the repair and I'm no newbie.

この回答は役に立ちましたか?

スコア 0
コメントを追加

Have you tried resetting the PRAM? Maybe its a software related problem?

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Robert さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 0

今までの合計 1,543