TCL 40" LED TV Logo Loop. On/Off Power

I have a TCL 40” Led TV bought in Abu-Dhabi, UAE 2012. Suddenly the TV won’t work. There is power and it shows the TCL Logo and rebooted again and again. It’s Stuck up in a loop. I visually check the power supply and inverter board nothings seems wrong except the main board with 3 minor bloated capacitor. I replaced those capacitors and nothing happen.

Any possible fix guys? Please help!

Block Image

Block Image

Block Image

Block Image

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 1

コメント:

Hi @judez415 ,

What is the model number of the TV?

Since it boots as far as the logo OK it may be that there is a firmware problem with the TV.

Search online to see if there are any firmware updates available for the TV and then see if you can update it. This usually happens via the USB port on the TV.

I found these firmware update instructions for a TCL TV which outlines the procedure.

1) Verify your model number (model number located on back of TV).

2) Load the firmware update file onto a USB flash drive

3) Turn TV on

4) Take the USB flash drive and plug it into TV in the USB port of the TV

5) When the TV starts to read the update file, you will see a menu that asks if you want to update the firmware. Select "Yes" using arrows on your TCL remote control.

6) When "Yes" is highlighted, click OK on your TCL remote

7) After upgrade is complete, a message will appear that tells you the upgrade has been performed successfully

8) Pull USB drive OUT OF THE TV

9) Turn TV off

10) Wait 1 minute

11) Turn TV on

It may not be the same for your model so verify the procedure if you do find any firmware available online.

Search online for TCL (insert model number) firmware to hopefully get results.

Just a thought.

さんによる

コメントを追加