メインコンテンツにスキップ

モデルA1369、1.6、1.7または1.8 GHzプロセッサー、64、128、または256GBフラッシュドライブ

379回答 すべてを表示

Hard Drive Not Recognized After Replacing Logic Board

I recently replaced a failing logic board on a 2011 Macbook Air. The install went smoothly, but on start-up, I get the question mark symbol indicating that the SSD isn’t being recognized. However, when I boot into Recovery Mode, it sees the SSD just fine and even lets me verify/repair. The hardware test also recognizes the drive and gives the computer a passing grade.

I suspect this is a firmware issue. The Macbook Air was running High Sierra, but I have no idea what the firmware situation was on the replacement logic board. I don’t know how to update the firmware if I can’t boot into the OS.

Any advice on how to update it?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 2
コメントを追加

1 件の回答

選択されたソリューション

Reboot the system and hold the Option key to get to the startup manager. You could be able to then select the SSD as your boot drive. It you are able to get it to boot up then you just need to go into the Startup disk settings to alter it.

このアンサーは役に立ちましたか?

スコア 2

コメント:

Thanks, Dan. Holding the Option key boots it up into Internet Recovery Mode, which gives me the start-up disk option, but there’s literally no disk to choose.

But I found another thread that looks promising.

Hard Drive/OS not recognized after logic board replacement

It says that High Sierra updates the drive to the APFS file system, which older OSs can’t read. This user reverted back to Mountain Lion, then went through every update.

I’m hoping this is my issue, too.

さんによる

Interesting! I've not played around moving drives around that much, But, I think I get whats happening here!

Your new logic board still has the older firmware on it (during the upgrade to High Sierra your system got it). Here this logic board still has the older one that doesn't know about High Sierra yet!

So you'll need to setup an external drive doing the OS install on it from Sierra or older to High Sierra. To make this work you'll need to pull the internal drive out before you do this.

You are right the issue is the new file system APFS but not in the way you are thinking. The drive in its self is not the issue here. It's the systems firmware.

さんによる

Thanks, Dan! I wouldn't have thought to disconnect the internal drive first. I'm hoping to give this a try tonight.

さんによる

It took a while, but it worked! I booted off an external drive with the Mountain Lion installer. I had to work my way though the successive OS installers, which took a while, but now the laptop boots normally.

さんによる

Happy it all worked out! Don't forget to score the answer and accept it as resolved.

さんによる

コメントを追加

回答を追加する

Lauren M さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 4

過去 30 日: 14

今までの合計 1,154