メインコンテンツにスキップ

2014年9月19日に発売されたこの4.7インチ画面のiPhoneは、iPhone 6 Plusの小型バージョンモデルです。モデル番号はA1549、A1586、A1589で識別できます。

5198回答 すべてを表示

PMIC gets warm when charging

I have an iPhone 6 that came in with water damage. There was the classic C5202_rf short on VCC_Main, which I removed and the short is gone. The phone will now power on, but is stuck boot looping (white apple, black background) and the PMIC gets warm. It only seems to heat up when I have 5V USB hooked up, if it's just the battery I haven't noticed any heat. Any ideas on where I should look for the short?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 1
コメントを追加

3件の回答

選択されたソリューション

Before anything else, did you do a proper decontamination of the logic board (remove shields, ultrasonic bath, Branson EC, IPA rinse etc)? If you didn't do this initially, then you should do it now.

Once you've done that I would start by going "bare bones". Disconnect everything from the logic board except the Battery and Dock. Connect an iTunes enabled computer and run 3uTools (www.3u.com) to see if the phone is still rebooting. If it is, then it is most likely a logic board issue (it could be the dock though).

If you suspect a logic board issue, check PP_BATT_VCC, PP_VCC_MAIN (which you already did) and PP5V0_USB. I would start by checking to see if those rails are shorted to ground. If one of these rails is shorted to ground, then you will need to identify what is causing the short. It could be a bad decoupling capacitor, conductive debris or defective IC that is directly supplied by those rails.

Then you move onto the PMIC and check the voltage rails it generates. The PMIC generates ~15 voltage rails. They are all important (for obvious reasons) but the ones to check first are as follows:

  • PP_CPU & PP_GPU, PP1V8_SDRAM & PP1V2_SDRAM, PP_VAR_SOC & PP0V95_FIXED_SOC, PP3V0_Tristar & PP3V0_NAND, PP1V8_ALWAYS, PP1V0.
  • The PMIC also generates, what I would consider secondary, yet still important voltage rails for the following sub-systems: PP3V0_MESA, PP1V8_VA_L19_L67, PP3V0_PROX_ALS, PP3V0_PROX_IRLED, * PP3V0_IMU, PP3V3_USB, PP3V3_ACC

このアンサーは役に立ちましたか?

スコア 5

コメント:

Thanks for your reply. I have removed the shields and done an ultrasonic cleaning. However it was with a cheaper cleaner that doesn't have frequency sweeping. I've been doing some component testing, I'll try to test those rails right now. For testing purposes I am using a known good dock connector and a known good battery/DC power supply. I'll reply with my results, thanks again for your reply, you gave some very helpful information

さんによる

C1700 and C1754 are on PP5V0_USB right? There appears to be continuity to ground on both sides of both of these caps. The only other points that seem to be in that circuit are a resister a coil and one pad under the PMIC

さんによる

C1700 and C1754 are on PP3V0_TRISTAR.

さんによる

I found and repaired the short. The PMIC still gets slightly warm but to me it feels like an appropriate amount of heat under normal operation. However the phone still boot loops. You mentioned using 3utools, could that correct the boot looping?

さんによる

コメントを追加

Sounds like you found an solved a pp3v0 Tristar short. Great job--was it the little cap by the dock?

After this, the next thing to rule out is software. If you had a short on Tristar and since Tristar is part of the main i2c data communication bus from CPU then software corruption is next most likely. Restore phone and see if it passes restore.

このアンサーは役に立ちましたか?

スコア 3

コメント:

It was the little cap that's just under the "frame" EMI shield that usually has a sticker over it, some solder from the shield had created a bridge.

Thank you. I have never used 3utools, when I restore it will the phone lose it's data?

さんによる

If it needs restore, then yes. If it needs update then no. 3utools is just a front end for iTunes. There is an option within 3utools to allow you "preserve user data" during restore--but in my experience this is just the same as update within iTunes. I would use iTunes for update first, and if it doesn't pass then I'd use iTunes to Restore.

さんによる

The phone doesn't register with iTunes. When plugging it in the phone will power on, and continue to boot loop but iTunes never recognizes that it has a phone plugged into the computer. Could this be a Tristar issue? When plugged into 5V USB voltage to the battery terminals fluctuates quickly from 3.5-4.0 volts and the voltages around Tristar seem to be normal. Thank you for your time and help.

さんによる

It won't be recognized by iTunes while in a corrupted software boot loop--put it in recovery mode and then restore.

さんによる

I installed a test screen with a home button to put it in recovery mode. When I hold the home button and plug the phone into the computer the iTunes logo doesn't pop up, instead I just have a constantly backlit black screen. After unplugging the phone and plugging it back in it resumes boot looping.

さんによる

コメントを追加

Try testing with a new battery.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Travis さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 2

今までの合計 1,053