メインコンテンツにスキップ

This model was released years ago and continues to be produced. The disassembling is straightforward as long as you follow the instructions.

8の回答 すべてを表示

How do I disassemble my Wahl Stainless Steel Lithium Ion + Groomer?

I researched and bought a Wahl Stainless Steel Lithium Ion + Groomer to help me stay within regulations as I was deploying to the Middle East.

During my research I found a number of complaints about the on/off switch failing and the ability of the groomer to accept a charge.

Initially the unit I bought worked well and had no problem with either the switch or charging. However, after owning it for about a year with light use, both of these problems emerged and now I can only turn it off by inserting the plug in the recharging jack.

In order to repair/troubleshoot the problems I need to know how to disassemble the razor/groomer.

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 3

コメント:

Anyone able to find a good source for replacement batteries with soldering tabs?

による

コメントを追加

6回答

選択されたソリューション

Hopefully this IFIXIT guide will help you: Disassembling of Wahl Lithium Ion Trimmer

この回答は役に立ちましたか?

スコア 3

コメント:

This link won't work because it's for the regular lithium ion, not the stainless steel. I have this problem too because I can't find a safe way to remove the silver led display off to get to the screws inside. Faulty production engineering?

による

For the stainless trimmer you'll need to pop the rubber power button off to access the screw under it. Use a thin knife point to get under the rubber and pry away from the shaver. After that, you can get to the two case screws under the bezel.

This is all a moot point due the the fact that I have ohmed all the hard wires on mine, only to find that there is something within the boards that is not allowing it to accept the charge or that will initially start charging, but then stop shortly after. It may be that the battery is sending out a false full charge signal...TBD

による

コメントを追加

Here’s a picture of the 9818L model and the placement of the hidden screw.

Block Image

Here’s some other pics of the 9818L (Lithium Ion+® Stainless Steel) that might be helpful:

Block Image

Block Image

Block Image

この回答は役に立ちましたか?

スコア 3

コメント:

mine is not charging light goes on but turns off

による

コメントを追加

Solved my problem! ! I used the shaver until it died, plugged it in and left. When I came back hours later, my trimmer wouldn't turn on, and if I plugged it in the blue light would flash and do not more. While attempting to disassemble it, I discovered the screw under the power button was loose and partially backed out. If I pressed the power switch without the button in place, the razor tured on. By tightening the slightly, everything works normally

この回答は役に立ちましたか?

スコア 2

コメント:

Thanks for sharing that! I have exactly the same problem with mine. Can you please describe how did you manage to get behind the button as it looks glued in. Thanks again

による

The rubber power button is glued to a plastic backing piece. slide a small flat-head screwdriver down beside the rubber and the plastic backer and the button will pop right out. The plastic has close tolerance, so you must use a small instrument. I just did it again with a knife, but tore the rubber a little.

による

I had the same problem- it seems to the thing with this unit- after a couple years that little screw must vibrate loose. All tightened and working perferctly! Thank s people!!

による

コメントを追加

I had this same problem. Plugged in the power chord, blue light flickers, if I turn the chord a little bit it gets stable (makes contact) and then after a few seconds blue light off. I first thought the problem was just poor contact, which is a PROBLEM in my case because if flickers at first, but not the main problem as the light goes stable after good contact and them off after a few seconds.


As it turns out this model comes with a RED plastic protector, some king of plastic plugg to protect the DC socket. It's a small individual part you can put it in when you are not using and take out to use the trimmer.

When that plastic RED protector is plugged it protects agains water/humidity/etc AND the trimmer won't turn on. The same when you are charging, the trimmer won't work. So, I found that when you plug something in the DC socket there's a very small mechanical switch inside that prevents the trimmer to work.


So back to the beginning, the blue light goes off after a few seconds meaning the battery is fully charged. You plugg out the power chord and nothing. WHY? Because the mechanical switch is ON, in my case it was jammed, stuck in that position. I opened it all, did a bypass to that mechanical switch and VOILA, everything working normally.


So, what is my problem right now? I worked around the mechanical switch thing, but sometimes it does not charge, because the DC connector is bad, after me trying to clean it, end up forcing it, as I thought it was a calcination problem (not sure if this is the right term, calcination), I mean full of grey dust which prevents a good contact.


SO, now I need to replace the DC socket BUT don't know which type/size is it to look for it for example in ebay.

Does anyone now what type of DC SOCKET is it? Any reference? DC-003 maybe?

この回答は役に立ちましたか?

スコア 1

コメント:

Hello,

I'm having the same issue as you describe. How did you bypass the mechanical switch? It's so small, and the switch is encased inside the small grey plastic housing.

If you find the DC SOCKET, please let me know!

による

I found the DC socket, replaced it and the unit is now workding fine. No more blue light flickering.

Bought in ebay: "DC-003 3.5x1.3mm DC Power Jack Socket Connector 3-Pin Panel Mount Plug"

による

コメントを追加

Just use a skinny blade phillps head screw driver or something thin like a feeler gauge to pop

the external button out , its just a pressure fit. I think the external button itself is the most of the problem

with these . Its either misaligned in the case of always on or worn off on the actuator knub that hits

the actual switch is worn down.

The first picture doesn't seem to show a model 7818

この回答は役に立ちましたか?

スコア 0
コメントを追加

Looks to be the charging plug not making proper contact inside the charging receptacle. I am not sure how to get it to work properly.

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Jim Mikkelsen さん、ありがとうございました!
統計データを表示:

過去 24時間: 23

過去 7 日: 101

過去 30 日: 695

今までの合計 19,575