メインコンテンツにスキップ

Sony Xperia Z3 発売日:2014年9月(グローバルモデル) 日本国内取り扱いキャリア docomo(SO-01G)・・・2014年10月23日発売 au(SOL26)・・・2014年10月23日発売 Softbank(401SO)・・・2014年11月21日発売

127の回答 すべてを表示

Vibrator motor not working

So I replaced the screen on my Xperia Z3, then I re-installed everyhting, and everything works except the vibrator motor, I thought maybe I broke the motor so I bought a replacement power button assembly (that has the mic and motor) I replaced it, but it still doesn't work. I didn't replace that tiny little piece that it connects to, because frankly I can't find it for sale anywhere. Do you think that is it?

Any solution?

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Hi Max

Usually the vibrating motor is on the cable with on/off and volume buttons. If you replace that cable and the motor doesn't work maybe the cable is faulty.

Hope you fix it soon.

による

コメントを追加

Android 修理キット

A new screen or battery is one kit away.

ショップを見る

Android 修理キット

A new screen or battery is one kit away.

ショップを見る

3回答

The vibrator motor is connected to the ribbon cable, Next to the motor there is a connector that gets plunged inn. There is a pink rubber insert that covers the motor that helps with vibration and noise. The motor will still work without the pink rubber insert.

That cable is very fragile, most likly it was damaged during installation.

この回答は役に立ちましたか?

スコア 0
コメントを追加

maybe your screw very tight, loose a bit.

この回答は役に立ちましたか?

スコア 0
コメントを追加

I exactly have a same problem.

I replaced my lcd, then the vibrator & mic doesn't work.. so I replaced the main flexible. The mic is working but the vibrator just stand still.

Still have no idea,

Is there any possibility it caused by the software error or something ?

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Max M さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 1

過去 30 日: 14

今までの合計 2,681