メインコンテンツにスキップ

USB ports don't work

Hi! I've acquired a number of 1ghz and 1.2ghz 12" g4 iBooks, and while trying to connect webcams, I realized that the USB ports on a few of them don't work. I proceeded to try mice and USB drives and piles of other USB devices, which didn't work either. The mice occasionally showed the red light underneath, indicating they were receiving power, but they were never recognized by the computer. FireWire works fine. All machines have leopard, and other similar machines from the same batch as these do not have any problems with USB ports. I've reset pram and pmu, removed all accessories, re-imaged the machines, and all the obvious stuff. Anyone have any ideas? Out of many hundreds of iBooks, I don't think I've had this issue, and now I've got three of them all at once. :-)

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 2

コメント:

Also, System Profiler does show the ports, so it's not as if the machine doesn't see them at all (such as when an optical drive is disconnected, and therefore is not listed).

さんによる

コメントを追加

2件の回答

選択されたソリューション

This turned out to be the DC-in. I guess the bad DC-in was not allowing enough power into the machine for the USB ports to function?

このアンサーは役に立ちましたか?

スコア 2

コメント:

+

さんによる

コメントを追加
最も参考になった回答

thats most likely a contact issue, had this on many computers.

most usb problems are contact related - one possible problem could be "low voltage" related - measure the voltage of the usb port with a multimeter (and in your case i'm pretty sure that you have at least one of them) - use this pinout.

the other problem is that the contacts are "worn out" - or better, simply a little bit bent and not able to close the contact when you plug in an usb device.

このアンサーは役に立ちましたか?

スコア 3

コメント:

+ reminds me of the old peanut butter sandwich in the tray loading disk drive. Check for gunk buildup on the receptical reducing contact.

さんによる

yummee - but i thought about a different food while reading your comment - i thought about "liverwurst" (lol - funny that "leberwurst" gets only half-translated)

さんによる

+

さんによる

Hi Markus! Thanks for the response! Believe it or not, I don't have a multimeter...I should probably get one. So if the multimeter shows low voltage, or if the contacts are worn out, there isn't really anything that can be done about it, is there? It all just comes down to the fact that the ports don't work, and I have to live with it? Thanks!

さんによる

i think it's time to get one. usb ports don't die - if they are not working, it's most likely a contact ptoblem - but for now, let's focus on the measuring and if the voltage is ok, lets try to get the contacts working again. if the voltage is not ok, measure it on the board side of the usb ports

さんによる

コメントを追加

回答を追加する

rdklinc さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 1

今までの合計 2,078