メインコンテンツにスキップ

Canon's Rebel XT is one of Canon's early entry-level DSLR's. Also marketed as the EOS 350D and the EOS Kiss Digital N.

28の回答 すべて表示

I keep getting an error 99

I tried to take some pictures with my camera recently and it keeps giving an error 99. I tried cleaning the lens contacts, I even tried using a different lens as I have 3 for this camera that didn't work. I tried a different CF card as I have 3 of these also and that didn't make a difference. I have tried with the flash and without the flash, even tried without a lens at all and everything I tried resulted in an error 99. I am going on vacation in 2 days and would like to resolve this myself if possible or I won't be able to take the camera with me. Please help

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 3

コメント:

I started having the same issue after I bought a CF card adapter and trying to use a MicroSD card. So I inserted a microSD card into an SD card adapter, and then inserting the SD card adapter into the CF card adapter. The CF card adapter was an EyeFi adapter and the microSD was Sandisk. Seems like my camera is fried. So sad.

による

The manual says.. Remove and re-install the battery. This doesn't always work in my case.

による

I have the same issue, error 99 and have to power cycle off and on to do anything.

Only a problem with one of my lenses though, so not as bad as yours.

Said lens got barged into by another tourist while on holiday and I get the error only on f5.6 apeture. I'm going to teardown the lens one day to inspect.

Will post findings if I have anything to report.

による

I get this problem only with thev28-55 lens that came with the camera. My other prime lens and the zoom lens works fine. Should I replace the basic lens?

による

コメントを追加

PCラップトップ用バッテリー

An easy fix for a big power boost.

ショップを見る

PCラップトップ用バッテリー

An easy fix for a big power boost.

ショップを見る

3回答

最も参考になった回答

I have the same issue, error 99 and have to power cycle off and on to do anything.

Only a problem with one of my lenses though, so not as bad as yours.

Said lens got barged into by another tourist while on holiday and I get the error only on f5.6 apeture. I'm going to teardown the lens one day to inspect.

Will post findings if I have anything to report.

この回答は役に立ちましたか?

スコア 1
コメントを追加

I had the same problem, especially when I use the flash. The problem in my case is that the camera got wet (just a sprinkle of rain while a Disney). Now every time the flash pops up, I get the error. My solution so far has been to use an external flash. Hope this helps

この回答は役に立ちましたか?

スコア 0
コメントを追加

It seems to be shutter unit fault.

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Kim さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 2

過去 30 日: 28

今までの合計 1,307