New LCD turns off during boot, otherwise works fine!

I am using the exact same model as the original LCD, and when I boot up at some point the loading circle freezes and the LCD turns off and goes to the external monitor. No matter what I do this happens, booting off external drive, also repaired permissions and the disk, reset PRAM and PMU. The LCD appears to be completely off, not just the backlight.

After booting into OS with external monitor in "Displays" preference pane the internal monitor does not seem to be recognized. Following this I only get the descriptor for the external monitor: http://www.ehow.com/how_8331885_determin...

The weird thing is that it works forever seemingly (15 minutes plus) if I just leave it at the "select boot disk" screen. Is my new LCD just not compatible somehow?

This seems so weird... can someone please help??

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Is this the same machine that was repaired by Apple?

による

If you're referring to a post made by me many months ago the answer is no. Don't think it was ever touched by Apple.

LCD bought off eBay.

による

Please give us the history of this machine. Was the original LCD doing the same thing?

による

The computer was fine with the only exception of the occasional vertical line across the screen until the display was closed with a pen on the keyboard and the LCD was physically broken.

The eBay LCD says it was refurbished which leads me to believe something odd is simply wrong with it. Or any other ideas?

による

コメントを追加