メインコンテンツにスキップ

修理を始めるには

修理する権利

パーツ&ツール

24" display; Built-in iSight Camera, Microphone, and Speakers; 1920x1200 resolution. Released October 2008, identified by model number A1267.

70の回答 すべてを表示

Backlight issues here's how I fixed mine!

@John &Io Nut

I have an LED cinema display 24" from 2009, I have excatly the problem that the screen blanks out after a 1 sec flash of the image (probably LED driver signal turns down). I was about to try the bypass solution above for the 3.3V drive input, but then wanted to ask first if the same backlight strip probem problem could be on my LED Display as well, because I would not want to loose the dispay dimming possibility.

update:

So I did take the LG LCD panel apart in search for the notorius LED Strip, see pictures:

Block Image

Taking the LCD apart:

The LCD frame,

Block Image

The Backlight panel,

Block Image

The plastic frame,

Block Image

Block Image

The glass of the panel,

Block Image

The back plate,

Block Image

Finally getting down to the LED Strip

Block Image

So I did resolder the LED connector (just added some solder to it and re-heated the 5 pins again thoroughly), but my problem still persists, the LED stripe only flashes quick at connection display port connection time. I am considering of doing some logic measurements tonight with my oscilloscope for the LED driver, but the willi fix for bypassing the 3.3V is starting to sound tempting (still trying to find out the real reason for this failure, and I have to admit that the LED stripe fault sounds more plausible to me due to the drive signal LED shutdown after one second flash.

Update (23.02.2017)

@io nut

I made some advancements with the display but the reason for the fault is still unclear.

All of a sudden the LEDs decided to turn on again.

Block Image

I am convinced that it has something to do with the horizontal positioning of my setup. While lit I quickly checked the LEDs and realised that Led nr. 27,30,40 and 60 are out. Next day when I started the display the background lighting did not lit again.

I figured it might have something to do with grounding and tried out connecting the displayport without the USB cable. No effect the LEDs turn on with or without the other USB connector and/or the Powerconnector. I realised that the LED cinema display brightness can not be adjusted without the USB cable connected to the my macbook pro.

Block Image

Update (26.02.2017)

LED illumination pattern 2/3 Leds.

Block Image

LED illumination pattern every third LED

Block Image

Update (27.02.2017)

So after all the MODs my display is running again. Eventually I ended up only changing 9 capacitors (3 pcs of each of the black ones in the pic, the orange ones I still have originals) on the powersupply,

Block Image

and resoldering the LED stripe connector,

Block Image

in addition I assembled and reassembled the display several times (loose connectors).

So Im still not convinced about the source of the fault and Im now testing the display for a week, lets see if it actually stays on.

Update (05.03.2017)

My Apple LED Cinema Display 24" is still up and running.

Update (03/22/2017)

Unfortunately I have to report that my LED cinema display died again after one month of fluent usage. So Im back to square zero. :!

Update (15.05.2017)

I decided to try out if my display runs and it seems to run again :). So lets see for how long, but I am suspecting some sort of capacitor voltages that are incorrect due to capacitor ageing.

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 2

コメント:

Robert, excellent pictures !

If you are absolutely sure you have resoldered properly the connector, and the symptoms are the same that means the problem must originate somewhere else. Your symptoms are different from the ones I have experienced, but it definitely sounds like a detected fault triggers the backlight to shut down. (is it just the backlight that shuts off?- do you have an image on lcd if you shine a light on the lcd?)

Does the whole strip light up during that 1 second? Noticed any LED stay unlit?

Is the octopus cable ok? Tried different one? (Yours could short out, like mine did initially).

Cover all your bases and now that you got so far, do not rush ! Ultimately, try the bypass mod, but in a non-destructive way, so you can undo it if necessary.

さんによる

Thanks for the rapid answer. I basically ruled out the octopus cable malfunctioning because I actually managed to start the monitor, but only the first time. So I got a nice and bright (with backlight) picture, but as soon as I restart the monitor the backlight just blinks and then shuts down again, probably some capacitor malfunctioning in the Logic board.

I did not realise any dark LEDs during the very brief flash of the LEDs (cant say for sure though). So I basically now have the monitor open and plain LEDs connected to the Logic board.

I ll try to get another octopus cable somewhere to try out, I havent tried that yet. Though I think the cable is not the fault since I have succesfully turned on the monitor 3 times (always after a long break or disassembly to let the charges out).

How would you do the bypass in a non destructive way? I mean once I have the resistors out it could be quite a challenge to get them back into their places.

さんによる

Non destructive way, meaning do not cut traces or destroy the 0 ohm resistors when you take them out. Use two fine tip irons ( or one tweezer tip preferably) and heat up both ends of the resistor at the same time and lift it off the board. Save it on a sticky tape in case you need to put it back on. Solder it back the same way, but use some flux on the pads. It is easy.

さんによる

I am assuming, you have done the firmware update for both the monitor and the macbook...?!

さんによる

I am actually running an old macbook pro mid2010 15" OSX 10.9.5 so it still has a display port instead of thunderbolt port, the firmware update I found would not install saying "your computer does not need this update " propably due to the fact that I have a display port instead of the never thunderbolt port.

I also tried the Macbook pro of my girlfriend, mid2010 13" running a OSX 10.11.6 El Capitan.

さんによる

3件以上のコメントを表示

コメントを追加

Manta Driver Kit

どんな修理にでも対応可能な112ビット

Upgrade Your Toolbox

Manta Driver Kit

Upgrade Your Toolbox

1 件の回答

選択されたソリューション

Update (2018/09) My display is still up and running after changing the Capacitors, but I reckon this is only coinsidense. I would advice you to have a look at James Stuart comment/explanation below. I think it makes the most sense and explains the cause of the problem well!

この回答は役に立ちましたか?

スコア 1
コメントを追加

回答を追加する

Robert Nawfal さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 11

過去 30 日: 119

今までの合計 626