メインコンテンツにスキップ

Fix Your Stuff

Right to Repair

Parts & Tools

モデル番号A1502/2.6GHz(Turbo Boost使用時最大3.1GHz)もしくは2.8GHzTurbo Boost使用時最大3.3GHz)デュアルコアIntel Core i7、4MB共有L3キャッシュに変更可能

332の回答 すべてを表示

Why is my MacBook screen display colours so distorted

My screen colours went funny while watching a YouTube video. I initially restarted the device to resolve it but now its seems to be permanent. I've reset SMC as well as NVRAM/PRAM

I've connected it to a external display monitor and the issue doesn't appear on it. It must be the internal display or its cable.

Block Image

I’ve attached a few photos here. https://imgur.com/a/GGnq5rq

As you can see the Mojave background is red and all wacky. Images of people look distorted and the screen looks foggy (not really visible in image)

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 2

コメント:

Does the issue happen in safe mode? https://support.apple.com/en-us/HT201262

さんによる

Yes. It still appears. Also when you change the display scale in the display settings there is a split second where everything looks fine when it transitions to the new display scale and then as it finishes it's back to the glitchy screen.

さんによる

I also have the same issue, Any help

さんによる

@omvratsharma - I've replaced a good dozen of these displays. Often the logic at the bottom gets damaged by liquid cleaner dripping on to it when people clean their screens (corrosion).

さんによる

コメントを追加

4件の回答

最も参考になった回答

The display will need to be replaced the logic within it has failed.

Here’s the needed part MacBook Pro 13" Retina (Late 2013-Mid 2014) Display Assembly You’ll need to follow this guide MacBook Pro 13" Retina Display Mid 2014のディスプレイアセンブリの交換

MacBook Pro 13" Retina (Late 2013-Mid 2014) Display Assemblyの画像

製品

MacBook Pro 13" Retina (Late 2013-Mid 2014) Display Assembly

$498.99

この回答は役に立ちましたか?

スコア 2

コメント:

No need to replace the display, check the UI elements, all primary colors are there, the screen is fine.

さんによる

@tomchai - Yes the solid colored objects have the correct colors, only the textures areas are messed up. Don't forget the external display is showing the correct image.

I'm thinking the switching logic within the display has a failure (bad capacitor?) Don't forget this series uses DP signaling between the logic board to the display (iDP)

さんによる

The color shades on icons is perfectly fine, so the screen is working exactly as it should. I believe this has something to do with rendering and composing images on lower layers, or GPU driver/config/hardware defect.

In any case, the DP line between the GPU and the display is working absolutely perfectly, otherwise the UI elements will also glitch up.

さんによる

@tomchai - The external image is OK so its something in the internal display logic thats has the issue.

さんによる

I still suspect this is due to software configuration, look at the hard drive icon on the top right, the greyscale is perfect. Due to the complex hardware and software architecture used in modern OS multi-display support, software issue CAN result in weird rendering artifacts only seen on one display.

I would suggest booting off an external drive or reinstalling the OS before trying anything from the hardware side.

さんによる

1以上のコメントを表示

コメントを追加

After checking the screen image, your screen is ABSOLUTELY FINE.

This is most likely some kind of software issue.

この回答は役に立ちましたか?

スコア 0

コメント:

Sorry Tom this is a classic case of corrosion damage. The display has to be replaced.

さんによる

コメントを追加

Hi Thomas,

Same MBP Retina, very similar problem here for almost 2 weeks. The way the colours are distorted is not quite the same, but it may be well just a different representation of the same issue (I will try to post an image when I get home).

In my case, everything started while normally using the laptop: just checking some websites with Chrome and switching back and forth to an IPTV stream on VLC. Suddenly, everything looks a bit ¿saturated?, then it went back to normal; after a few minutes, the same problem again which continued intermittently, more frequent every time, until it finally became permanent.

Restarting, resetting the NVRAM and the SMC didn’t solve it. I just switched the laptop off and next day it looked the same, BUT… after a few minutes the screen recovered the original, normal colours. That last just for a few minutes, but it was there… only that it wasn’t for long. That behaviour continued; I also detected that, when the colours were distorted that way, the screen presented very clear image retention.

Last Friday I hooked up the laptop to an external 24” monitor, where the image is shown just fine. I left the MBP display as the secondary one, and it happens that… for 2 hours the desktop’s background image was fine, then it went distorted again. I created a white *.jpg with the same resolution than the screen, and opened it to full screen; when I do that, the display always fixes itself for a variable period of time.

I have an appointment today with a Genius, but guess what… I have been using the MBP for 3 hours now and the display is fine. I would like to show him how the thing looks when distorted.

If you find anything please keep us posted, I will do the same.

Thanks!

PD. Finally I cancelled my Genius appointment given that I couldn’t reproduce the problem today. And this is my screen:

Block Image

この回答は役に立ちましたか?

スコア 0

コメント:

@ksillas & @imkaran - The humidity in the air can be a factor here. Corrosion is like a sponge, it's only causes issues when it has water does it become conductive.

What you do to keep your screen clean is a big factor! Using a spray directly on the screen is a big No No! Instead spray the cloth you are using to wipe the screen! This removes the risk of the cleaner from dripping down into the displays logic which is not protected!

さんによる

コメントを追加

Hi,

I’m facing the similar issue. Can you please tell me, how did you get this problem resolved?

Thanks in advance

この回答は役に立ちましたか?

スコア 0

コメント:

Test your system first! Plug in an external monitor if it looks OK then you know the issue is your internal display. Review my answer above.

さんによる

Hi Karan,

Sorry to hear that, it was a very annoying situation for me. Unfortunately, the only thing I can say is that the problem suddenly disappeared after 1 month, with no action from my side. I hook it up to an external monitor where the image was just fine, and I could still see the strange colors in the internal display; one day it became normal, and till today no more issues.

Best regards.

さんによる

コメントを追加

回答を追加する

Thomas さん、ありがとうございました!
統計データを表示:

過去 24時間: 28

過去 7 日: 146

過去 30 日: 507

今までの合計 2,230