メインコンテンツにスキップ

モデル番号A1286、発売日 2011年2月/2.0, 2.2もしくは2.3 GHzクアッドコアIntel Core i7プロセッサ

573の回答 すべて表示

Dim green light on magsafe, doesn't charge but boots fine if connected

Hi!

I’ve spent the last few days browsing tons of posts about dim green light magsafe connectors but still haven’t found a similar case.

I’ve bought a MBP that had dried up thermal paste on the CPU and GPU which caused overheating. The charger was working fine, bright orange or green light.

I took it apart, installed new paste and after putting everything back together the charger will not charge the computer and will only have a very dim green light on the connector.

When I connect the magsafe power supply the light is very dim, even when the board is out of the case with nothing else connected. I do not see any corrosion on the board, or any damaged components.

An SMC reset does nothing

A PRAM reset does its thing but doesn’t solve the issue

Using Coconut, I can read the battery info (serial, temperature, cycles, etc), it sees that it is connected to AC and it also says that battery is not charging. It currently runs at 1.6% (74mah)

I tried a different power supply which works with another Macbook but I have the same issue.

I cannot find schematics of the one-wire circuit on this computer so I cannot verify the voltage (I dont know where the chips are).

Do you have any advice?

Thank you!

Update (10/05/2018)

MagSafe connected

Block Image

Block Image

that’s all I currently have on my cellphone. Like I said in my original post, the computer can read the battery info.

I have tested with a known good adapter already and it shows the same behavior. I dont have a spare dc in board to test but I have already ordered one yesterday

Update (10/05/2018)

Block Image

here is a screenshot of Coconut with magsafe disconnected

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

2回答

最も参考になった回答

Not good ;-{

You appear to have damaged your logic board. There are a few different possibilities.

  • Didn’t work on a static free work surface and/or did not use proper ESD precautions.
  • You over did the thermal paste and it’s shorting out the other logic on the chips base (some paste is conductive or capacitive).
  • You snagged one of the small SMT components dislodging it
  • You damaged one of the connections.

Any one or more of these could explain your issue. I would go back and clean off the thermal paste if you see any had gotten off the silicon chip its self

Block Image

Inspect the board for any damage as well as the cable connectors (both the board & cable sides).

この回答は役に立ちましたか?

スコア 1

コメント:

All connections are good (everything is functional: fans, keyboard, backlight, speakers, screen, mic, dvd, hdd, power button).

I am using a very low electrical conductivity paste and I made sure to apply only the minimal needed amount of thermal paste so that it doesnt overflow on the chips.

The computer runs just fine, but the performance is throttled because there's no battery power.

Do you by any chance have the plan of the board so I can find out if there is voltage on the 1 wire circuit?

による

OK lets dig a bit deeper on the battery logic. Install this app CoconutBattery post a snapshot of the main window so we can see whats happening. Do one with the MagSafe connected and a second if you can with the MagSafe pulled. Then place them here for us to see iFixitでの質問に画像を追加する方法

As for schematics there out in the wild of the big i-Net. I don't think you need to go that far yet. Lets first see if the basics get you going. You might want to review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters and make a good inspection of the MagSafe connectors for any dirt, burning or melting. You may only need a new charger or DC-In board.

による

I agree with Dan, first troubleshooting step would be to test the logic board with known working magsafe adapter and DC in board.

による

Well, I tried another magsafe connector and power block but the same issue remains. The dim light. And now the computer wont even turn on because the battery is too low :(

による

Sorry guy as I suspected you damaged your logic board. The SMC logic on the back side of the logic board is damaged. At this point I think you'll need to send your system out to have the logic board repaired or you can just replace it.

による

表示する 3 他のコメントを

コメントを追加

I had this problem but push the magsafe connector to the port and wiggle it around works good to me

この回答は役に立ちましたか?

スコア 0

コメント:

Unfortunately I am way passed this point :(

による

Its ok

Man see ya

による

コメントを追加

回答を追加する

vizi0n さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 0

今までの合計 126