メインコンテンツにスキップ

モデル番号A1707。 2017年6月に発売されたこのMacBook Proは、最大3.8 GHzのTurbo Boost搭載の最大2.8 GHzクアッドコアIntel Core i7プロセッサーまでのKaby Lakeプロセッサーを搭載しています。

274回答 すべてを表示

Left fan stuck at high speed

I spilled a little water on the keyboard and immediately dried it out. The laptop functioned perfectly fine after. I was worried that there could be some water deep inside so, a couple days later, I removed the logic board to clean underneath it. There was not any water there. I used canned air to clean out dust, and a hairdryer to make sure there was no water. After reassembling, the left fan has been stuck at full speed whenever the computer is running. I did not remove the fan during this cleaning.

I am using iStat Menus. The thermal sensors appear to be fine.

Block Image

I am able to use iStat Menus to set the fan speed for the right fan but the left does not respond to the controls.

I tried resetting the SMC and PRAM. I ran an Apple Diagnostics and it said there may be a problem with the fan. I installed a replacement fan and the problem still persists.

What can I do to get the fan under control? Could the heat from the hair dryer have damaged the fan connector or its circuit?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 3
6 件のコメント

@tbertin Hello! I have same problem on my MBP 15’ 2017. How did you solve this problem?

さんによる

Hello! I have the exact same problem. The left fan stuck at 6500rpm and the right fan is fine. The left fan is also not manually controllable by the Fan control software like TF Pro. How did you solve the problem? Thank you.

さんによる

Did you ever get it repaired or looked at by a company that does component level repair?

さんによる

I did not fix it. It likely needed component level repair which was not worth the cost to me.

さんによる

has anyone solved this issue ? my A1707 has the same issue after the battery is replaced.

By the way, can I just use it with one fan spinning at full speed all the time ?

I just want to use this macbook for one more year, and then I will get a new one.

さんによる

1以上のコメントを表示

コメントを追加

8件の回答

選択されたソリューション

I seriously doubt canned air would have damaged anything on the logic board..fact is that even if a small amount of water reached the board it might have shorted out a secondary but certainly not useless component.

Fact is that due to the size of parts it's hard to see anything with less than 10x magnifying and often one can't see anything at all and just needs to test power/data lines. If it spins full speed and a replacement fan and smc reset didn't help it's likely the fan speed control data line or related component got damaged. I'm afraid you'll need a component level repair professional here.

このアンサーは役に立ちましたか?

スコア 2

1件のコメント:

Thank you. That makes sense.

さんによる

コメントを追加

Hi! I have the same issue and I found out one of my transistors, more specifically Q6050 was mising from my board. It was yanked out most probably during reassembly. (Oh yeah, and a resistor too)

Block Image

As you can see the trio of black resistors and the transistor in between should be complete each fan but the one at the bottom has missing parts.

Block Image

The transistor is the black block while the resistors are the silver ones with a black middle. I've ordered these parts online and I'll get back if it fixes the issue.

このアンサーは役に立ちましたか?

スコア 2

4 件のコメント:

Same for me, thanks. Seems that keyboard ribbon connector cause damage to it, when left under system board.

さんによる

Could you help me understand what is MOSFET? I googled it and I see it's a chip. How do I identify it for my MacBook?

さんによる

this is ridiculous, why are macs so ridiculously touchy and purposely difficult to work on? honestly compared to lenovo they are junk. maybe the m1 is better, but if made the same they are junk. don’t defend them because it’s apple, they should be better than this. i like apple but i know they cut many corners. now do i blame them? !&&* no, because people don’t complain.

さんによる

I have a 2017 A1707 mlb 820-00928 with high fan speed only on left fan. HWMonitor not showing any high temps which doesn't suggest a sensor issue. I was thinking that it was possibly a PWM issue from damaged/missing components so I Googled and found this thread. Mine was the same issue, missing Q6000 the mosfet for left side fan. https://imgur.com/a/BQ1LDYj Two pads missing and the left hand pad had a via under it which goes to pin 19 of KBRD connector. I repaired the pads with some jumper wires see here https://imgur.com/a/zaExsx9 Thanks to the other posters for their info #righttorepair #repairnotreplace

さんによる

コメントを追加

You’ll need to run the onboard diagnostics to see what it tells you. Restart your system and hold the D key. That will get you in, once you get an error code let us know. Depending on what you get you may need a new fan or you forgot to connect something.

Reference: Mac startup key combinations

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

i have mid 2015 15” Macbook Pro, its right fan is showing 5700 rpm max but left one is 6156 rpm max at mac fans control app. Shouldn’t they be at same rpm? Or is it normal as default?

このアンサーは役に立ちましたか?

スコア 0

5 件のコメント:

on my 2016 15" Pro Left 5927 Right 5489, seems that it is normal

さんによる

@Sergey Alright thank you!

さんによる

just recover broken MOSFET (you need a donor board, microscope (lens is not enough), and small soldering iron, if trace is broken you will need a thin wire also) and FAN control will be available again.

さんによる

Check Q6050 and Q6000 on board and resistors near too. For model A1707.

さんによる

Exactly! Thanks!

さんによる

コメントを追加

I already bought the missing parts but the problem is I need quite a bit of skill as well as a hot air workstation. Hopefully someone would be able to fix theirs using the info below:

Here is the fan control circuit on the board (It’s missing a MOSFET-[Part#Q6050] and a Resistor-[Part#R6051])

Block Image


Here’s the location of the parts on the board

Block Image

Here’s the diagram for the fan control circuit

Block Image


Finally, here’s the parts that you need (They’re really tiny haha)

Block Image

このアンサーは役に立ちましたか?

スコア 0

3 件のコメント:

I got issue can't seem to find the location for left fan components A1707 macbook 2017

さんによる

Very lucky at the end damged component were found while i was puting A1707 togather keyborad flex which were lefted under the mainboard and pressure cased the damaged to component,reslodered same one but did not work so i have to run a jumper and worked for me

さんによる

@Syed Shah Loor right under the keyboard connector. Bottom side of PCB. You need to remove the board.

さんによる

コメントを追加

In A1707 the location of the mosfets is right under the keyboard connector (oposite side of PCB). In my case the components were still there, but the left fan was running at full speed all the time. Did a reflow (apply solder paste and then hot air with SMD solder station) but it did not work. So, I bridged the Drain pins of both mosfets and now both fans are controlled by the right side driver. There are test pads for the Drain pins, so solder is easy by bridging those pads.

The laptop seems to be working fine with both fans controlled together, but you can install Mac Fan Control or similar app to assign more sensors to drive the good mosfet.

このアンサーは役に立ちましたか?

スコア 0

2 件のコメント:

can you upload a picture how did you made it? thx

さんによる

Can you share a picture of the work you did? Was it relatively easy?

さんによる

コメントを追加

I’ve had the same issues plus gradual disappearance of thunderbolt ports functionality for a couple of years. And I resolved those all just today by replacing the original ports with couple of ones from AliExpress. To be honesty, I was afraid to completely break the device, and when I booted after replacement and have still been seeing same issues, I’ve thought “at least it is alive” and go for a rest. After a couple of hours without any resetting of SMC or PRAM it shouted up the fans (silence! finally!) and gradually kick up the ports so I finally can use HDPI 4K@60Hz, full-speed external hard drives and firewire audio interface via thunderbolt. It is epic win for just a $20! \ 0 /

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

画像の内容を見る:

Block Image

Block Image

このアンサーは役に立ちましたか?

スコア 0

1件のコメント:

When you removed logic board this component check it must have been lose or damdged this is on other side of the right under where you plug cable for keybaord

さんによる

コメントを追加

回答を追加する

Tristan Bertin さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 26

過去 30 日: 95

今までの合計 4,594