メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

Yellow and blue patches on new LCD

I decided to get my old 2008 silver non-retina Macbook Pro 15" which I hadnt used for years back to life. Only half the screen was working, the battery was dead and a fan was running very slow. Replaced the battery, the fans and checked the display connectors and they seemed to be all ok so decided to replace the screen.

An original display assembly was cheaper than just the LCD (!) so replaced the whole assembly. Now even after replacement, I see these blue and yellow patches on the top of the screen and some ghosty shadows around text on screen. I also feel the LCD pixels are more visible (or maybe I am just spoiled by retina screens). I noticed the same patches and ghost on the half broken old screen.

The display connectors are all new and I cleaned the connectors on the board before installing it. Could this have something to do with the display IC on the motherboard?

Any help would be much appreciated. Thanks!

Block Image

Block Image

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

I read about the GPU issues with this model. Could it be just that? If it is, I will not spend any more time on salvaging this.

さんによる

Sorry about the late response. Just got around to playing with this laptop again now. When I login to the recovery mode by holding down Cmd + R, the display looks perfectly good. Could it just be the display driver?

さんによる

コメントを追加

1 件の回答

選択されたソリューション

This series uses the main RAM for video. See if a fresh set of RAM modules improves things otherwise the LVDS cable may have some slight damage.

この回答は役に立ちましたか?

スコア 2

コメント:

Thank you for the response. Works well in Recovery mode. Could it just be the display driver?

さんによる

The GPU its self still has RAM (128/256 MB of SDRAM) within it.

When you use the lower res mode all you're doing is using the onboard RAM Vs using the systems RAM as well. And you also are using a lower refresh cycle.

Did you try a second set of DIMM's? Did you also try reseating or replacing the LVDS cable?

If neither of these effected things then your logic board its self has an issue. It's likely the GPU chip is failing here that was a common issue in this series. NVIDIA had a bad run of chips and even the good ones also failed over time if you didn't keep the system clean of dust build up as that effected its ability to keep cool which over time stresses the GPU's internal flip chip solder joints.

さんによる

コメントを追加

回答を追加する

Vatsan さん、ありがとうございました!
統計データを表示:

過去 24時間: 2

過去 7 日: 2

過去 30 日: 19

今までの合計 2,328