メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

The Shark Rotator NV502 vacuum was made in 2013, weighs 15.5 pounds, and includes a lift away handle. The vacuum can be used on both carpet and hardwood floors.

11の回答 すべてを表示

Why won’t my vacuum turn on?

I've pushed the 'ON' button on the vacuum , but it wont turn on. What can i do?

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 5

コメント:

Yesterday mine just stopped. The light is working, it's not clogged up. Nothing happens at all till I drop the handle and then the brush roller spins but that's it. No suction or anything. Put the handle back in the upright position and everything stops. ????? Help.

さんによる

Exactly what is happening to mine!!

さんによる

Same = see my answer below

さんによる

Mine just started doing the same. How do you fix it?

さんによる

Mine too grrrr

さんによる

5件以上のコメントを表示

コメントを追加

13件の回答

選択されたソリューション

First, make sure the vacuum is plugged in. If the vacuum is plugged in and the switch is pushed on, but it's not turning on then try to reset your circuit breaker or reset the motor thermostat. The steps to reset the motor thermostat can be found in the troubleshooting guide.

この回答は役に立ちましたか?

スコア 4

コメント:

This is not the question asked. The brushbar turns (so the power is on) and there is no suction.

さんによる

mine was doing the same thing, the power to the brush would turn on but the actual motor was not. The switch was not operating fully. I took mine completely apart, cleaned the switch and now it works perfectly. It took about an hour and most of that was locating the screws. Also, you will need 2 different size torque bits in order to do that! Hope this helps.

さんによる

Just put together a brand new Shark navigator. Will not turn on. Totally dead. Great product.

さんによる

コメントを追加
最も参考になった回答

The collection canister has a switch that engages when it locks in that can wear and not function, try removing the waste canister/collection canister and insert it carefully to attempt to engage the switch

この回答は役に立ちましたか?

スコア 9

コメント:

Thank you so much! It was that simple.

さんによる

Perhaps the newer models have this switch, but mine doesn't. I'm thinking mine is either fried, or the cord is worn in the vacuums interior.

さんによる

The canister removal and replacement did it. Thanks!

さんによる

6/23/19- This works! I can’t believe it was this simple, stupid. I went through every hose and removed all the strings on the brushes. Been playing with it for 30 minutes until I found this “ifixit” web site!

さんによる

Thank you! That was simple..

さんによる

2件以上のコメントを表示

コメントを追加

Thermal Protection Switch. (For mine)

Clear any obstruction - I found a clog in both sides of the removable elbow below the wand.

Let it cool off for a 15 -30 minutes with the cord unplugged. Some thermal switches will not reset as long as it’s plugged in.

Reassemble if needed, plug it back in, turn it on, and clean.

この回答は役に立ちましたか?

スコア 2
コメントを追加

This just happened to me and the issue is the power switch. If I short the switch leads with a screwdriver (after disassembly), the vacuum runs. Now where can I get a new switch...

この回答は役に立ちましたか?

スコア 1

コメント:

Gloria it was very simple thanks Joey. What a relief!!!!

さんによる

Same problem for me. It only turns on when brush is engaged and handle down. I've cleaned the brush and filters. Brush turns on but the power doesn't come on until I pull the handle down as if to start vacuuming. But no suction. Can anyone help?

さんによる

Hi Carrie, did you get a solution to your problem? I have the same prob.

さんによる

I have the same problem Carrie

さんによる

Same problem as Carrie.

さんによる

コメントを追加

It's likely the thermal overload which is that 1/4" back thing with two legs coming out and a short one in the middle.

Solder a link from the middle of it to the black wire and you will bypass it.

Keep the vacuum clear and you should have no problems.

You will have no thermal overload for the motor so the next time it may burn the motor but it beats throwing it out

この回答は役に立ちましたか?

スコア 1
コメントを追加

Same thing just happened to me, there is power because when I lower handle for brush roll, it works but no suction and when handle is up then nothing, no noise or suction. Crazy, me red and white on worked for years and I have had this less than a year, going to try to use warranty. This model is the purplish one, professional with attatchments, not the slim one or anything, just a better version of my red and white professional one.

この回答は役に立ちましたか?

スコア 1

コメント:

Hey I have this exact problem now. Did you get yours figured out Christina?

さんによる

Any answer? Mine is the same. No power til lowered and no suction, but brush works.

さんによる

Lisa, Carrie or Christina? Have any of you found a solution? I'm having the same issue.

さんによる

コメントを追加

In our case, the vacuum just stopped working right in the middle of use. My wife was using it when it happened. When I came home we both looked at it and concluded the roller and lights worked when they were supposed to, bu the vacuum motor itself was not running. Reading this wiki , the motor thermostat seemed like the right answer, but it had been down for well over an hour and should have cooled down by then.

We then UNPLUGGED the machine (it had been plugged in the entire time). Went to dinner, came back, and it worked just fine. Going to clean the filters so it doesnt have to work so hard.

この回答は役に立ちましたか?

スコア 1
コメントを追加

Do the vacuum have to set for awhile until it's cool off

この回答は役に立ちましたか?

スコア 0

コメント:

So what too do

さんによる

hi, mine did same thing and when I checked the front filter I noticed it was hot. Was yours hot, did you get it fixed?

さんによる

コメントを追加

Nothing happens at all when I switch ours on. No light no noise no nothing. Any ideas?

この回答は役に立ちましたか?

スコア 0

コメント:

Same with mine. I was literally just using it and it was working fine, and no nothing.

さんによる

Just bought the cordless shark duo clean today put it on to charge the charging lights came on fine and is now fully charged but when I turn it on it is completely dead the only power it has working are the charge lights????

さんによる

I’m having the same issue, were you able to get your resolved.

さんによる

コメントを追加

I have the Shark Apex Vacuum. I got it for Christmas. I was just using it to suck up dirt on the floor. Went to turn it back on but the rollers won’t roll. The light on the vacuum comes on and then the light starts to blink. Help!!!!

この回答は役に立ちましたか?

スコア 0

コメント:

Hope to hear back with an answer soon.

さんによる

Reset the unit by turning it completely off and wait for 2-3 minutes before turning it on again. This will reset the vacuum cleaner’s system and fixes the errors or bugs inside.

さんによる

I have the same problem with shark rocket vacuum. Suction motor works. The roller does not work. There is light on the board. I removed the roller cover and directed the power supply. Now the brush roller and the motor works. I can’t figure out when I attach the suction motor, roller won’t work but there is light on the board.

さんによる

コメントを追加

We cleaned the filters as it said on the label by the filter and now it works like new.

この回答は役に立ちましたか?

スコア 0
コメントを追加

I have the shark duo clean. Lights work but no motor. I was vacuuming and the motor stopped. It's only 6 months old. I unplugged it for 30 minutes, cleaned the filter, and mad sure there's no clogs. Motor still not working. Only the lights.

この回答は役に立ちましたか?

スコア 0

コメント:

I have the shark duo clean as well. Switched it on and it suddenly went off

さんによる

Pat Voeks mine is doing the same thing. What did you end up doing?

さんによる

コメントを追加

Hey everyone.. thanks so much for this forum. I didn’t see any answers to mine, so here it goes. My motor turns on, suction works, but no light at all to the indicator light on top of the roller part. I have cleaned all parts, made sure there are no obstructions, made sure all parts are clicked in together and no dirt in the plugs. Still no light on indicator… help please ??????

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Samuel さん、ありがとうございました!
統計データを表示:

過去 24時間: 109

過去 7 日: 775

過去 30 日: 3,535

今までの合計 169,494