メインコンテンツにスキップ

Model A1200 with 2.16 or 2.33 GHz Core 2 Duo processor

113回答 すべてを表示

iMac - turning on but screen is black and no sound

Hi there!

My iMac worked without any problems for 7 years. A few days ago has sharply turn off the screen.

On pressing the power button there was no response. Disassembled case, when plugging in burned one diagnostic LED. Reinstall the memory. Started on and lit up all 4 LED's, fans worked well, audible diagnostics of DVD but black screen and no sounds from speakers. No sounds of HDD reading.

The question is what to change the inverter, motherboard or video card?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 1
コメントを追加

2件の回答

ベストアンサー

As you state the HD is not starting up either (no startup bong) I suspect your power supply is gone.

Remember you have multiple low voltage taps so some ares of the system may be working while others not.

But the real question here is why your power supply went. Do you have a surge suppressor or UPS? Did you get hit by lightening?

このアンサーは役に立ちましたか?

スコア 1

5 件のコメント:

No UPS or other power devices. Directly to the power plug. No lightening. I think this is age of iMac. (((

さんによる

Surge suppressor & UPS can protect your system i.e. Power supply. While you do need to replace the power supply consider getting a good surge suppressor at least for your system and system's peripheral devices. Yes, age can also be the cause but more often I see power surges as the issue.

さんによる

Dan, thank you for your attention. But all 4 diagnostic LED's lit up! Why? I am ready to buy new power supply but not sure about this decision.

さんによる

OK that does change things. Lets start the diagnostic process again here. Review this Apple TN and tell us how far you get: Intel-based Mac: Startup sequence and error codes, symbols

さんによる

Dan, thanks. Great article but nothing useful for me. All that I hear and see after pressing power button:

1. Power LED on and slow down off - absolutly normal.

2. DVD-ROM sound.

3. Coolers start working on maximum speed.

4. I hear special electronoise like turning on LCD display, but nothing on the screen.

5. That's all - no boot chime, no HDD reading sound - nothing, only noise of coolers.

さんによる

コメントを追加

This was about the end of the period of the bad capacitor issues but I'd look at the capacitors on the power supply and elsewhere, and see if any are swollen or leaking.

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

回答を追加する

Max さん、ありがとうございました!
統計データ:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 11

今までの合計 2,453