2012年6月12日に発売。Turbo Boost付きのインテルプロセッサー、モデル番号は A1278。

1216の回答 すべて表示

MacBook Pro dropped - acts slow now and fan is always on very loud


my Macbook Pro fell down , the screen got cracked and the fan is running at full speed. Also the system is overall running very slow, the cursor is jerky.

I ran both , Apple Hardware Diagnostics and Apple Service Diagnostics and it gives an error at Ts0p palm rest sensor. (also on extended AHD Test)

But I dont get it. ASD tells me that it can read a value and states an SMC IO error.

I opened up the machine and have the schematics here with the corresponding brd file of the logic board.

Can anyone give me a hand what to do ?

Ah yeah, I almost forgot to mention the most important thing. People on the internet are talking about the sensor being inside the Trackpad or on its flex cable. So I got my hands on the Macbook pro mid 2009 from my friend and swapped the trackpads along with the flexcables.


Did another SMC reset before testing and the fans still went crazy as before, nothing changed.

My trackpad and cable however worked flawlessly in my friends macbook .

So the Trackpad shouldnt be the problem.

Any ideas?


I ran ASD OS and here are the 3 failed test from 84 tests

Local machine info: Mac OS X version = 10.8.2(12C3104) IP Address: ASD version:3S155

ASD Log activity from [07/20/14 01:50:03] to [07/20/14 01:52:35]

[07/20/14 01:51:55] * TESTING STARTED *

[07/20/14 01:51:55]     Temperature (Ts0P) -- Palm Rest (test #1) - Sensor Reads Within Operating Range

- Check to ensure that sensor reads within operating range.

[01:51:56]     ERROR -- 1 [Unable to read sensor] -- TEST FAILED

[07/20/14 01:51:56]     Temperature (Ts0P) -- Palm Rest (test #11) - Extended Sensor Flat Line Test

- Checks that the Sensor changes value i.e. not stuck, with longer time allowance for change (5 mins).

[01:51:56]     ERROR - -13005 [The SMC can not read this sensor] -- TEST FAILED

[07/20/14 01:51:56]     Thermal Interface - Processor:Processor0: TIM Test 75 percent GB (test #4) - TIM Test 75 percent GB

- Check that CPU heatsink is properly attached, using product spec theta dh + 75 percent guardband.

[01:52:35]     ERROR -- 255 [Unknown result-code 0xff] -- TEST FAILED

[07/20/14 01:52:35] * TESTING FAILED [Elapsed time = 00:00:40]  *

Update 1:

Alright Images aren't shown in Comments , so here is another attempt

Block Image

also this is a screenshot from terminal (that's probably because the SMC is in kind of emergency mode or smthn)

Block Image

Update 2:

Here are the temperatures btw. PCH seems a bit high to me. Shouldn't it be lower if the fan is constantly running on 6000rpm?

Block Image

Picture battery

Block Image

Update 3:

Here are some measurements

Block Image

Update Monday 21st

The SMBUS_SMC_2_S3_SCL and SMBUS_SMC_2_S3_SDA seem to be the culprit!

I think I have a bad SMC chip or the two soldering points of the BGA are faulty. But there is 4.3V right? A cold soldering point would implicate no current at all ?

How do I know that it's the two lines mentioned above? Well, all the PP3V3_S3 probes on the bottom side of the board show 3.3V. Everything correct on that end of the line.

So it would make no sense at all if the camera + ambient light sensor (=ALS line) would work and the Sudden motion sensor (=Digital SMS).

Well check this out:

I opened up photobooth and camera (which I never use) didnt work!

System Profiler also says no camera connected!

Alright, I booted up ASD OS and ran an Ambient Light Sensor (ALS) test.

It told me to cover the ALS which I strongly believe is next to the camera. Used my big thumb and covered it. And the ALS test actually failed!

Previously I thought the ALS is ok, since I thought it passed the particular test in the standalone tests. However I now realized that in the standalone test it checks the Ambient AIR Sensor. Interesting to know that there is actually a sensor which recognizes your farts but the point is I thought by mistake that I previously checked the ALS sensor, which it seems I didn't.

The ALS sensor check is only offered in the interactive testing, and it failed.

Although at some point I believe it mentioned to cover "both" sensors. Where is the other one, if there is one?

I tried to cover the microphone hole too but it failed. So if anyone knows if there is another one please tell me so I can repeat the test.

Alright. So technically I'd guess that the Sudden Motion Sensor which is also on the line should be defective. However I am not sure how to check this.

The test didnt offer any checks. So I went to terminal and checked the SMS with sudo pmset -g and the sms was set to 1.

Then I tried to disable it with sudo pmset -a sms 0 and it seemed to work.

And then reenabled it with sudo pmset -a sms 1. And it was 1 again.

Technically the SMS works. I don't know if that makes sense.

Block Image

Block Image

Update (07/20/2014)

Hi Dan!

thanks for the answer!

Here are the results from coconutBattery

Block Image

回答がありました! View the answer 同じ問題があります


スコア 1


OK, thats good we know the SMC is working as the battery/charger status wouldn't show up. But your Active monitor snap shows the kernel task is going overboard. Was the system running when you dropped it? If it was I would guess the HD is hurting. Heavy kernel task often implies the CRC of reading/writing to the disk is failing causing it to retry and retry until it gets it to or from the disk.


That can explain why the built-in AD the condition and ASD shows the system is OK. Remember Apples Diagnostics works off of OS of the system Vs the Apple System Diagnostics works under its own OS from the external disk.


Yeah the system was running when dropped, but somehow the HD is totally ok. It doesnt give any errors or sounds weird. Also I tried to swap the HD with no effect. When booting off a USB 3.0 thumb drive to install OSX it acts the same. Very slow.

Same goes for booting the ASD Hard drive.

I didnt quite catch what you meant when you compared ASD but let me tell you which I used.

First thing I used was the Apple Hardware Diagnostics that is loaded when pressing and holding D while booting (Connects to the internet like the internet recovery)

That's when I saw the Ts0p error for the first time, in both quick test and extended test. That was also the only error.

Secondly I tried Apple System Diagnostics EFI 3S155 (thats the version iirc) .

It also showed the Ts0p error by telling SMC IO error

At last I tried Apple System Diagnostics OS 3s155 (also from external hdd) and basically the output is shown above.


Sorry I mis-read your results. Need another cup of coffee this morning ;-}


Do you have access to another logic board for this series system? Try installing it to see if the errors are following the logic board. If they do then something must have gotten whacked. Do you see any damaged components or dents in the bottom cover that could be pressing on something?


表示する 3 他のコメントを



Only $29.99

Buy Now


Only $29.99

Buy Now



Alright, this it the answer. Problem is solved: (for clarification: mousepad is a member in macrumors forums)

Alright guys.

So in case anyone is interested, here is the documentation.

When Mr. mousepad told me to measure some points on the top side of the logic board I had to unplug several connectors since it's impossible to make the measurements with keyboard and HD cable etc plugged in.

So with only the battery, Trackpad and fan left (iirc) , I shorted the power on pads to power on the machine and at first I even didn't realize that the machine turned on, since there was no display attached I relied on the fan noise which used to spin at 6200rpm .. and you can't overhear that.

But actually when I looked at the fan I saw it rotating very slowly and quiet and I was like wow I've had headaches for the past couple of days because of this friggin fan noise and this is exactly how quiet it should be when I'm working with it.

Nevertheless I thought that it's not a big deal and the machine just doesn't properly boot up and that it's in some kind of pre boot phase, where the fan doesn't go crazy yet, with some important cables not plugged in (HDD etc)

But I went on and made my measurements on Probe 1517 and 1518 I believe it was (the SMC lines coming from Trackpad , ALS, Digital SMS)

I got correct 3.3V.

So I turned the logic board around and retook measurements on the 6 points I posted earlier at R5270 and R5271 and so on.

All of a sudden I got 3.3V at all six points now!

I started to think that by unplugging one of the cables I sorted out the culprit.

So I plugged back in all the cables that didn't have much to do with the problem: HDD cable, Superdrive, Audio, Keyboard, Display, BIL

And the only thing I left unplugged was the iSight camera+ALS cable which shares the specific SMC line with trackpad and SMS.

I turned the machine back on, prayed , and it was fixed! Machine is totally usable right now: no kernel_task at 300% and no loud fan noise and no laggy trackpad.

Booted up ASD OS and checked the sensors and Ts0p was fine! All checks passed.

Afterwards I plugged back in the cam/ALS cable and the Ts0p showed up again and the fans started kicking crazy again.

And I am very ashamed because the problem seemed to be ovious. Well at least for non-complicated people (which I am not).

As I told you after the drop the glas of the screen cracked and it has some severe cracks near the left frame and the top left frame just next to the camera. It's so shattered in that area that you might cut your finger when swiping over the glas.

Meaning that either the cable or the camera and ALS board underneath is damaged.

So maybe I would've found the problem earlier after taking off the cracked glas if my replacement glas arrived.

Thanks again to mousepad and everyone helping me out. Especially thanks for the schematics and the brd.

If you have any questions feel free to ask.


スコア 2


Thank you so much. My customer had this issue and unplugging this cable fixed it.


Wtf are you talking about man, how is someone supposed to make sense of all this jargon. I'm not a computer whiz and my computer dropped and now I have constant pinwheels. I can't even acces any of my Microsoft Suite programs as they all crash.


I have exactly the same problem. Can you show me where the cam/ALS cable is, so I can disconnect it?



I think you are over focusing on the sensor side of the issue.

Instead, you need to look at your logic board. Given all of the other errors your SMC service is having issues.

Lets try a different tool here to see what it tells us. Give coconutBattery a try. While it does not test the SMC thermal sensors, it will test the battery side of things in SMC. What does it tell you?


スコア 2


Buco Escobar さん、ありがとうございました!

過去 24時間: 4

過去 7 日: 21

過去 30 日: 108

今までの合計 11,217