メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

27" display with 2560 x 1440 pixels resolution Thunderbolt & MagSafe cable attachments

143回答 すべてを表示

How can I fix my display blacking out intermittently?

I've had the Apple Thunderbolt Display for a little more than a year, and it has started to intermittently go black for a few seconds at a time. When it does, I usually lose connection to my usb devices connected through the display. If I let it go on, it blanks more and more frequently until the system kernel panics.

So far, I've tried cleaning the contacts with rubbing alcohol. This made them more visually attractive, but did not solve the problem.

Second, I tried using another macbook pro, but it had the same issue.

I've noticed that the thunderbolt connector heats up significantly when it's in use. I'm wondering if there's a heat-related issue that could be causing a broken connection in the electronics inside the connector. Any thoughts?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 22

コメント:

OMG same here I thought I was alone.

さんによる

@Julian - Make sure to get the firmware update (see below).

さんによる

I have found that the All-In-One Cable goes bad and results in an intermittent blacking out. I have had to replace mine every 12-18 months.

さんによる

I had the same problem, and it grew worse with time. The issue was the Thunderbolt cable failing just behind the computer thunderbolt connection, right where the cable protector terminates. Had the same issue with an IPad Thunderbolt powersupply cable. My gripe is that replacing the power/data cable for the display is a tedious and challenging task. A simple plug on the back of the monitor as other manufactures use would have been good, but noting that Apple does not sell the cable, my guess is that Apple wants the user to have to buy a new monitor. Sad way to do business.

さんによる

After having the intermittent blackout problem on my Thunderbolt display for years it seems that I have fixed it by replacing the cable. I made sure that the problem was indeed the built-in monitor cable by bypassing it completely using a normal thunderbolt cable plugged into the expansion thunderbolt port on the monitor (yes the monitor can be used this way, as long as you don't require another thunderbolt port for other devices), making sure that the problem was not with the thunderbolt port on my laptop. Well, I need that thunderbolt expansion port, so I bought a replacement cable on eBay ($23!). I did not need to buy the recommended pair of suction cups to pull the glass off of the display, I used a single GoPro suction camera mount, positioning it near the top left corner, it pulled the glass free with no drama-inducing excess force needed.

So to sum up, from my experience anyway, it's the cable. Not the firmware, not the power supply.

さんによる

13件以上のコメントを表示

コメントを追加

18件の回答

選択されたソリューション

The heat is expected as the Thunderbolt cable has some electronics in the connector which does heat up.

I would focus on the power supply in the display. Heres a similar Question Why is my LED cinema display switching on and off?

このアンサーは役に立ちましたか?

スコア 4

コメント:

Possible that it's the power supply, but the magsafe adapter still works. Also, when the usb connectivity goes down, the usb devices would still be powered.

さんによる

I agree with Mayer - Make sure you're not overloading things. The power supply inside the display has different voltage services, so its' possible the display power side is having issues and not effecting the MagSafe connection for the laptop.

さんによる

Have the same problem. Thought it was the all in one cable, so I bought some new and replaced the cable. Still the same issue. To me it seams that there is a problem with the heat somewhere. My display turns up but starts to flicker after a few minutes and then blacks out. The mag-safe power does still work and the thunderbolt cable is also still showing a connection to the iMac or Macbook which I have connected. And the speaker do work as well. I don't know if I should now buy a new Power Supply and change this part.

さんによる

You'll need to open it up to be sure. As it turns out the connection on the logic board is a Thunderbolt connector so you can use a standard cable to verify. Just make sure the cable is a Thunderbolt Vs mini DisplayPort which look the same! That is if you have a TB model and not a DP model.

さんによる

I added a USB fan to blow air to the connector.

I was facing this problem for some time now.

さんによる

1以上のコメントを表示

コメントを追加
最も参考になった回答

Using another Thunderbolt cable attached to the additional port on the display instead of using the built in cable solved the problem for me. At least I now know that it is the display cable and not something with my Macbook. Now I will get a replacement cable for the display. Can anyone tell me if it can be opened without suction cups, or are they necessary? Thanks.

このアンサーは役に立ちましたか?

スコア 10

コメント:

It can be opened without the suction cups, but it's kind of tricky. You have to be able to get between the glass and the body without damaging it, but you might be able to get a finger nail or a guitar pick in there.

さんによる

Thanks for the advice. I realized that I own a GoPro camera suction mount that should do the trick. Just need to go and order that cable. Cheers!

さんによる

using a separate Thunderbolt cable fixed the issue for me.

さんによる

After testing in three different monitors and a couple more cables got it working upgrading my miniDP-DP cable to a HBR2 ("High Bit Rate 2") compatible cable. StarTech.com MDP2DPMM1M

さんによる

You sir are a lifesaver, I have been battling with flickering on my Apple Thunderbolt display for a very very long time and never thought to use a different cable than the built in cable... connecting a separate cable to the thunderbolt port on the display has sorted all my problems and I am over the moon... thanks so much!! Such a simple solution that it was staring me in the face, haha!

さんによる

1以上のコメントを表示

コメントを追加

See if disconnecting all the USB and firewire you have that might be drawing power. See it the issue persists or takes longer to go out. It probably is a power supply but something may be drawing to much power.

このアンサーは役に立ちましたか?

スコア 3

コメント:

I disconnected the USB devices and the ethernet cable. So far, everything's working great! I'll see if it continues working. If so, you think a power supply replacement is the proper fix?

さんによる

What were the USB devices? Do any of them draw power from the USB? Plug in just one at a time for 20 minutes or till you get a failure. See if you can locate the offending power drawing device.

さんによる

if you still have the display you will need to change the device board this has caused most of the problems in this display.

さんによる

コメントを追加

try external thunderbolt display cable. i hope that will solve the problem. the heat you are noticing on connector is coming from PC which lead to connector. black out issue will be solved after the external thunderbolt monitor cable from apple.

このアンサーは役に立ちましたか?

スコア 3

コメント:

Do you mean that if I buy a new external Thunderbolt cable and connect it to the back of the display and then to my computer, it will solve the problem?

さんによる

No, that won't work. Thunderbolt is a TX to RX architecture. There is an expectation the attached cable in the display is connected to your Mac. The unused ports on the display are for a daisy-chained displays or other devices not the Mac system.

さんによる

To Dan,

This is incorrect. Thunderbolt is a bi-directional I/O. I have used a Thunderbolt Display with a separate Thunderbolt cable for years since the built-in cable was to short to reach the computer. The built-in cable actually becomes your daisy-chain option...

さんによる

Well ... Yes & No ;-} In this case the fastened cable within the display is designed to go into the system (RX), the ports on the display are designed to service other Thunderbolt devices (TX). Which is the framing of my answer (and correct here). - The iMac & MacBook Pro systems have a different Thunderbolt PHY logic which allows them to be connected back to back which is where your answer is correct. If you remember back in the old days of 10Mbps Ethernet we had physical polarity within the cable connectors. If you wanted to connect two systems back to back you needed a special cross-over cable so the Tx connection went to the Rx of the other devices PHY. Later on improvements in the PHY's (100Mbps) allowed the signals to be switched within the Ethernet hardware, so you could use either a straight-though or cross over cable the systems would know how to configure them selves - Magically!

さんによる

To Dan I have a MacBookPro An Air and a Mini all exhibiting the same problem with the attached display cable. using the external Thunderbolt cable into the unused port cured my problem

さんによる

1以上のコメントを表示

コメントを追加

There was a firmware update that fixed the problem

このアンサーは役に立ちましたか?

スコア 2

コメント:

Good Catch! it came out in Nov '14. Here's the Link: About Thunderbolt Display Firmware Update 1.2 It's part of Mavericks 10.9.4 or later.

さんによる

Mine has the firmware update (1.2) and still goes dark, requiring unplugging and replugging the monitor to restart it. A bit of a pain. Some else solved this by not using the built in thunderbolt cable but running a new to the port on the back. I may try that next.

さんによる

I tried that, it still goes black but way less frequently .

さんによる

This did not fix the problem.

さんによる

コメントを追加

Hello everyone,

I've been experiencing the same or similar problems with my thunderbolt 27" monitor. Lost the USB ports and the camera, then it started to flicker and soon complete blackout. Well I read about the cable and how it might be bad, but for whatever reason I didn't go down that road. I chose to replace the power supply. That seemed to work, for about a day or two, before I lost the USB ports and the camera again. Then the display started to blink on and off. Needless to say I was pretty bummed. I was researching and found this discussion board. Well long story short I disconnected the "integral thunderbolt cable from my Mac mini and connected the monitor to the computer using a dedicated cable going to the "aux thunderbolt port". This was two days ago and everything seems to be working great. The only downside is that you lose the "aux" port. I does seem to be an issue with the thunderbolt connection inside the monitor. But that's a bit out of my league. Good Luck.

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

I still have the display (Packed away in the garage) and plan to take it apart one day to find the weak (possibly) cold solder joint in the power line that powers the Led backlight.

このアンサーは役に立ちましたか?

スコア 1
コメントを追加

turn off the sleep option, don't let it go to sleep. Mine would flicker occasionally and never wake up after sleeping. Turned off sleep function and have had ZERO issues in about 6 weeks.

このアンサーは役に立ちましたか?

スコア 0

コメント:

Works for a while then problem is back.. try turning the computer on then off and see what you get. a band aid solution. for a cash cow device.

さんによる

コメントを追加

Hi Guys,

I have the same trouble what we need to do is change the powers supply, Mine is completely dead now and went with a bang it flickered did all that crap that every one else's display is doing from the very first day I got 3 years ago.

I really don't think there is any thing apple about this display of mine any more, I have change almost all of the parts in this display and all I need now is the Australian conversion power supply.

I need to find out where I can get one and how to replace it, cost of the part, oh yeah I live in Australia so I really need Australian power supply for the LCD thunderbolt display.

I did not know they made a LED display there is no led lighting in the thunder bolt I have pulled mine apart many times to fix problem after problem and apple want to make you pay $100's of dollars to fix it.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

After having my TB Display "repaired" at an Apple store about a year ago, I recently put it back in service only to experience the sudden instances of loss of video (SILV) after 10-15 min of utilization. My next step was to use a separate TB cable instead of that supplied with the TB display. Same result! Having previously noticed the heat generated at the computer end of the TB cable, I put a large metal "paper" clip on the plastic connector to dissipate the heat. Much to my amazement, this appears to be a viable solution! Thus far, no occurrences of SILV and while the heat sink/paper clip is rather ugly, it does appear to be effective. If anyone else out there can recommend a more elegant heat sink, I'd love to hear about it ...

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Have a similar issue. If display brightness is set to above 70% after several minutes of use the screen goes black. Works totally fine if the brightness is below 70% (approximately). Replaced the power supply and tried a separate TB cable neither helped resolve the issue.

このアンサーは役に立ちましたか?

スコア 0

コメント:

Hi Yana. Did you find a solution? I have the same problem here...

さんによる

コメントを追加

Ok I know this is an old display but I love it.. except for the fact that it’s now black.. the build in camera works so I guess it’s safe to assume that the cable is fine (right?)… what can I do… is it really time for recycling this baby?

このアンサーは役に立ちましたか?

スコア 0

コメント:

I was able to get a thunderbolt cable and plug one end into my Mac Pro 2013 and the other end into the thunderbolt-in on the back of the display -- was pleasantly surprised to find the signal kicked on, has been stable, and allowed me to continue using the display (by bypassing the built in thunderbolt cord). Maybe worth a try. Note that my issue was flickering after 20 minutes or so (as if it was overheating). Was surprised to find the issue seemed to be with the built-in cord.

さんによる

コメントを追加

This is way late, but the heat thing resultant from the repeatedly stressed connection seems to be the issue. a.k.a. "Bad Design" See FLIR pic:

Block Image

https://ibb.co/h24jY7B

The connection is the hottest thing around by 20 degrees (case next to the connection is only 98˚)

このアンサーは役に立ちましたか?

スコア 0

コメント:

Yes, the MacBook Pro you have in your FLIR photo is running on the hotter side of things.

But I don't see the Thunderbolt connection as the cause but the CPU & graphics logic with is very close to this side of the system.

さんによる

コメントを追加

My display has been in my closet for over a year.. I have taken it in to Apple, and the guy tries to up-sell me on a new computer, claiming that my Mac is too old. Could you elaborate on the cold solder joint issue?? If this is a design flaw in the Apple product, why is Apple not stepping up and authorizing a recall.

We should be able to drop it off at the Apple store and get it back in 30 days, ready to go. They seem to be very quiet about this issue, which is causing me to be a little less locked in to the Apple products weakness that I currently have.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

same problem here - resolved with a new thunderbolt —> thunderbolt cord (2m for $39 at apple store), surprisingly the power supply connection still works as it should, now with a dangling and dead thunderbolt connector.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

I’ve had this problem on and off for months now. However, I’ve not seen the TB Monitor go black during use, rather when I plug it into my laptop, the computer sets up for the two monitors, but the TB Monitor is black. I’ve found two options to getting it working again:

  • disconnect the power to the TB Monitor and peripherals for a few mins, then turn it back on, and reconnect TB cable to your computer.
  • Disconnect other Thunderbolt devices on the chain.

One or other (or both!) of these things have always gotten the TB monitor working again for me. I’ve always been reluctant to try the replacement TB cable, as I would then lose the TB connection to all the devices I have chained off that port. Hence, constant noodling. But although it’s been really frustrating and it can often take me an hour of fiddling to get things back, it HAS always come back to life again.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Similar problem with second TB display (plugged with factory TB cable plugged into back of the TB 1) going black intermittently until it just quit coming on. Used a new Apple TB cable plugged into back of TB2 into back of TB1 , problem solved. Thanks to all of y’all’s comments I avoided a tear down which would probably have been fun.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Unfortunately I’m in a “throw it out or fix it” situation with this. My TB Monitor situation started to happen more often, and on a few occasions became a crisis as I can’t do my work without a second monitor (film editor). I bought a new Dell 3219Q monitor to replace it, but since the TB monitor does indeed work 98% of the time, I would love to find a way to fix this issue so I can have a large dual monitor setup. I know that, at least in my case, along the way I’ve disproved all the theories in this thread, including my own.

Here are things I know:

• If power to the TB Monitor was turned off for a while (overnight, typically), the issue would almost always happen - the computer would ‘see’ the monitor, all functions and things hubbed through the monitor would work just fine, but the display was black.

• I changed ports, cables, adaptors and finally even the computer, using a brand new MacBook Pro, but the problem continued no matter what I did.

• It’s not a software or firmware issue, either with the monitor (it has that last firmware update) or computer (because it happened with a different, brand new computer, running Apple’s off-the shelf Catalina instead of Mojave on the older computer).

• Once, the monitor just went black during the day as I was working. Everything continued to work just fine, but the display was completely off.

• Pulling the power to the monitor for at least 20 mins or more was the ONLY thing that could bring it back to life, but doing this for hours did not guarantee it coming back. In every case that the display has gone black, it has eventually ALWAYS come back - at some point. But I’ve had to leave it alone for a day or two to get that. Suddenly, it would just work.

•  I just went back to using the built-in cable ganglion and that works, and fails, just as much as a direct cable in into the back of the monitor did.

• I removed absolutely everything plugged into the back so there is no power draw other than monitor.

Given all the above, I didn’t bother installing the new laptop power/TB cable ganglion I bought here, as that’s clearly not the issue.

When working, it’s still a great display, and now that it’s just sitting on the shelf unused I’d love to crack it open and fix it if I can. Assuming the problem does not lie in the incoming cable ganglion or TB socket on the back of the monitor, and that it seems somehow connected to power issues, I’m going to try replacing the power supply, available here.

このアンサーは役に立ちましたか?

スコア 0

コメント:

This issue may remain forever a mystery. I had it with mine for years, with 2 different MacBookPros. I replaced the monitor's cable assembly, I've ran it via a TB port on the back of the display instead of the built-in cable, I've ran it without using any of the expansion ports on the monitor to reduce heat it the connectors. The issue always came back. The TB plugs on both of my MacBookPros always seemed like they made only the most tenuous connection, as the slightest bump on the cable would cause the screen to black out. But now after years of the issue everything seems to be fine. Haven't had it happen for months. Why? Well it is now plugged into a new M1 Mac mini. Why the issue doesn't seem to exist with this new computer is a complete mystery, but I'll take it. Could it be a laptop issue? It sort of seems like it in retrospect, at least for me. Best of luck with it.

さんによる

コメントを追加

回答を追加する

Sterling Hirsh さん、ありがとうございました!
統計データを表示:

過去 24時間: 13

過去 7 日: 148

過去 30 日: 651

今までの合計 104,716