メインコンテンツにスキップ

blank screen and shuts down after 10 seconds

iMac G5 17 Model A1058

when pressing power button on g5 imac it makes startup noise but the screen does not do anyting and then it shuts itself down after about 10 seconds

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 4
コメントを追加

2件の回答

選択されたソリューション

Open it up by removing the back. There are four diagnostic lights on the logic board. Let us know what they are telling you. Also inspect the 24 "cans" capacitors for swelling and/or corrosion.

このアンサーは役に立ちましたか?

スコア 4

コメント:

the capacitors by the processor have corrosion on the top...i picked this unit up knowing it was broken but am really hoping i can fix it for my little brother who loves apples (as do I). I'm pretty mechanically inclined so I'm hoping I can fix what happens to be wrong. I saw on another site ppl soildering new capacitors, is that a common problem for a unit this old? Thank for all you help.

さんによる

I'd also like to edit my original post, after opening up the unit and starting it from there I notice bootup sound, and HD cranks...still no screen....lights 1 and 2 stay a constant green. Before I thoguht it cut itself back off but after leaving it to see if the lights change i notice all the fans speed up to a highspeed. Hope this helps.

さんによる

Here's the most knowledgeable guy I know of on the capacitor problem: http://jimwarholic.com/category/imac_g5

さんによる

コメントを追加

I have the same problem: the boot up sound and the fans and HDD working but no picture on the screen. My leds 1, 2 and 3 are green and 4 is off.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Michael K さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 1

今までの合計 820