Why my calculator is stuck in the main menu?

Block Image

I just replaced the batteries for new ones, when I tried to turn it on: it appeared the main menu and now it’s stuck there. I’ve already tried resetting it, took out the batteries and put them back again, I’ve also tried to use the F2+4+Ac/on+RESET, and then press 9 and x, and still nothing happened.

It’s literally stuck on the main menu like the picture I’ve attached.

Please help.

この質問に回答する 同じ問題があります


スコア 1

5 件のコメント:

Could you post a video or pictures of what it's doing?


@garretjaworski Hi! I’ve added a picture for reference, it’s literally stuck on the main menu. It’s doesn’t respond to any button, can’t even turn it off with them: I have to take the batteries out to turn it off.


Try pressing the numbers on your calculator. It looks like the numbers correspond to a certain funcion.


@garretjaworski None of them work, the screen it’s completely frozen


I'm guessing the connector from the MB to the buttons might be disconnected or shot. Try taking it apart and checking.