Backlight stopped working after assembly iPad Mini

So my girlfriend couldn’t remember her iCloud email and unlock the A1454 iPad, I decided to try and remove r1204 and short r1205 to turn it into iPad Mini WiFi, that worked like a charm, it went into DFU and flashed the firmware.

After creating a new iCloud account, I checked if everything is working, and everything seemed OK. Powered the thing off and started putting it back together, EMI shields and all that, but when I tried to power it on before pressing the display back in, it stayed black, the backlight was not working.

Checked the L2200 fuse - continuity is there, as well as between the diode leg and connector pins, D8228 seems fine too, 3.8V on one side, 0 on the other, diode testing mode shows 0 in one direction and 2 and change in the other, hard resets and an additional DFU did not help, connectors look ok.

Honestly, I have no idea what else to look at here.

I was ready to throw this thing out when I decided to try and unlock the iCloud, but that work out great and this new issue popped out of nowhere, bummer =(

I really want to figure this out, please help

Update (10/20/2019)

Oh wow, just figured out, that 2.07V reading in diode test mode is the voltage drop, which for PMEG4010BEA used in the iPad should be around 0.54V, so it’s probably the diode after all, those things are 8 cent a pop, but I’ll need to grab some new tips for my soldering station to swap it ha ha

この質問に回答する 同じ問題があります


スコア 0