メインコンテンツにスキップ

修理を始めるには

修理する権利

パーツ&ツール

For all questions about Solid State Drives.

20の回答 すべてを表示

iMac Late 2009 won't recognize external SSD at boot

Hello,

I’m upgrading my iMac Late 2009 from a 2 TB HDD to a 1TB Crucial MX500 SSD using the kit.

The 1 TB SSD when connected externally is recognized when I’m running High Sierra. When booting, the external SSD is not seen at all during in the Restore mode/Disk Utility screens. The USB 2.0 adapter seems OK and is seen at boot when another 1 TB HDD is connected at boot.

I’m able to install and boot High Sierra from that. Want to do the external check before removing the screen. Is this a known problem with Crucial MX500?

Read online somewhere to try Samsung EVO 850 due to a SATA link negotiation issue.

Would be so nice to save this iMac from the recycle.

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

Nintendo Switch 修理キット

ゲームを再開するための、早くて簡単な修理キット

Switch 修理キットページへ

Nintendo Switch 修理キット

ゲームを再開するための、早くて簡単な修理キット

Switch 修理キットページへ

2件の回答

選択されたソリューション

Got the Samsung Pro 850 1TB working just fine. Will be returning the Crucial MX-500 in the kit. Ifixit folks, please take note and you may want to modify your kit!

Also, the metal drive adapter needed drilling out two holes with an 1/8 drill. The iMac original shock-mount stubs look like they use a 6-32 screw thread not the 3mm threads in the holes. The 6-32 threads were just the right size to self-tap.

So both the Crucial and Samsung SSDs were compatible with the kit’s USB 2.0 adapter, but the Crucial was not compatible on boot time with my iMac late 2009.

この回答は役に立ちましたか?

スコア 1
コメントを追加
最も参考になった回答

It sounds like your SATA to USB adapter is not able to support the Crucial SATA III (6.0 Gb/s) SSD.

この回答は役に立ちましたか?

スコア 2

コメント:

See if this fixes your issue SATA to USB Cable with UASP

さんによる

コメントを追加

回答を追加する

JOHN CHEN さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 1

過去 30 日: 9

今までの合計 136