Acer 1640 Old HDD u/s, new HDD not recognised.

Acer 1640, keyboard and screen too good to scrap!!!

The old 60 GB hard drive comes up as defective on boot and the o/s will not load/run. I have replaced it with a similar and known good, formatted, 60 GB, MK6025GAS, HD. (Formatted to Fat32, using EasUs Partition Master.)

When I boot from an external source, Linux Puppy USB or Linux Mint CD, the 60 GB HD drive (when installed in the machine) is not recognised when the Linux O/S is running, so I can't install the Linux O/S on it.

Similarly, if I try to boot from a Win XP legal Installation CD, the internal HD is not rercognised.

I want to load either Linux Mint or Win XP, as an O/S. prefer Linux, but if it can load XP I can then install Mint later on.

The replacement HD runs perfectly in an external enclosure on the USB, when running Linux, but not when installed internally.

(The laptop, will boot from the Linux USB/CD when there is no internal hard drive fitted.)

Any ideas?


この質問に回答する 同じ問題があります


スコア 0

8 件のコメント:

Hi @revicam ,

Is the HDD being "seen" in BIOS?



Sorry for the delay in answering.

No, the new HDD (FAT32) is not recognised by the BIOS.

If I format it to NTFS, Ex3 orEx2, it is still not recognised.

System and extended memory are recognised in BIOS and appear to be OK.




Hi @revicam

Being an older drive, have you set the "jumper' that you need to set on the HDD to denote it as a 'Master' drive as opposed to either Slave or CS or no jumper at all?

Also check your HDD 'boot' preferences in BIOS

Can you hear it spin up when installed in the laptop and the laptop is turned on?



No jumper links on the either drive and yes, drive "spins up" when laptop turned on. The original (Fujitsu) disk was dated 203-02, replacement (Toshiba) dated 2007

just to recap.

I've tried various combinations of formats, NFTS, FAT, FAT32, Ext2, Ext3, GPT,.MBR, set up by using EaseUs partition Master 12.9.

Also tried AOMEI Partition Assistant Standard Edition 6.0 and Macrorit Disk Partition Expert Free, but to no avail.

Old u/s disc is recognised as a failing one in the Acer laptop "Back up data immediately" message, and the system just hangs there waiting for a manual shut down.

The new disk not recognised at all. A screen message says "No operating system found press F1"



Hi @revicam ,

If I haven't got 'lost' then to me it is more of a concern that the BIOS is not identifying the HDD, even though it spins up.

This implies that the power to the HDD is there but the rest of connections (or at least 1 or more connection with this particular HDD) is not.

It would be different if the HDD was identified in BIOS and then the OS was not found. The HDD identity is preset in the HDD and 'read' by the BIOS.

Are the two HDDs identical as to their physical size, number of connectors etc.?

Have read in past where some HDD are 'thinner' and need to be 'supported' (padded out to make them thicker so they sit correctly aligned to the connector) to make good connection with the motherboard connection. Just a thought.