Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

529の回答 すべて表示

New Battery won't charge

Swapped out my battery It will not charge. Tried a different charger with the same result. Reset PRAM & SMC, same result. Laptop runs fine on AC power. When first plugged in the power connector shows a green light and I get one LED flash on one of the LED's that indicate charge level and then that LED is off.

Any suggestions?

Thanks

The charger stays green

Block Image

Block Image

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 1

コメント:

Does the MagSafe charger stay Green or does it get to Amber?

Download this app: CoconutBattery take a snapshot of the main window as well as the Battery info window. Paste them here for us to see.

iFixitでの質問に画像を追加する方法

による

コメントを追加

Pro Tech ツールキットを含むご注文、もしくは総額 $100ドル以上のご注文については送料無料です。

当社のショップを閲覧する

2回答

最も参考になった回答

Review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters

Make sure you are using a real MagSafe charger OEM MagSafe Chargers vs Cheap Imposters: Teardown for Truth & Lacking safety features, cheap MacBook chargers create big sparks

Your systems charging logic is damaged!

この回答は役に立ちましたか?

スコア 2
コメントを追加

I have this same problem with my early '09 MacBook Pro 17" and new battery.

Although it ran on the AC adapter fine, my 2+ year old battery was not charging, and the magsafe charge indicator never showed amber before, during or after boot up. After replacing the battery the problem persisted, even after resetting SMC and PRAM multiple times. The new battery has gradually gone from showing 100% to 0% charge., and the macOS status shows "battery is not charging".

Do you thing the after market battery is the issue?

CoconutBattery Info

MacBookPro5,2 \ Mfg 2009-2-23 \ OSX El Capitan

Current Charge 46mAh

Full Chg Cap 16500 mAh \ bar meter shows 0.3%

Design Cap = 16000mAh \ bar meter shows 100%

mfg date 2018-12-23 \ cycle count 80

macOS Batt status Good \ Batt temp 21.1 C

Charging with 0 Watts \ Power Adapter Connected

Battery Info:

MFG Simplo \ Age 61days \ Load cycles 80

macOS batt stat Good \ Batt temp 21.1C

Battery failure none \ Poweradapter 85Watts

Thanks, MJ

この回答は役に立ちましたか?

スコア 0

コメント:

I had a similar issue on a different laptop and I solved it by simply opening it up and unplugging the battery and just letting it sit for a little while. When I plugged the battery back in and powered it up the laptop was charging again. I don’t know if this will solve your issue on your laptop but it’s something to try :)

Best of luck,

Max

による

コメントを追加

回答を追加する

scohou さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 2

過去 30 日: 9

今までの合計 230