メインコンテンツにスキップ

モデル番号A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

537の回答 すべて表示

MacBook Pro 17" 2009 doesn't power on even after keyboard replacement

I've just decided to replace my keyboard since some keys don't work anymore. For this, I had to disassemble it. I've spent a long time trying to connect the keyboard flat ribbon and after finished, I'd power it on and it powered on normally. I turn it off in order to replace the back cover. When I've tried to turn it on, it didn't work anymore. No lights, no fans but the battery was still charging. I've decided to use the power pads to power it on and it works. I've then imagined being the new keyboard and I reconnected the old one. Surprisingly, it still didn't work. What could have been happened? Could somebody help me?

Cheers

=== ===

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

@gersoncruz did you ever get this fixed?

による

Not yet, but I discovered that the problem is on the mainboard. It works properly when the battery is connected but when I tried to use it only powered by the magsafe, it doesn't works. I don't know what could be happen, maybe some SMC issue.

による

コメントを追加

3回答

最も参考になった回答

If you are saying the problem is that it won’t boot without the battery, this is very common with the 17” machines. It seems the 17” needs more power to boot than the mag-safe will supply. Now if the machine is warm, it will sometimes boot.

この回答は役に立ちましたか?

スコア 2
コメントを追加

If it works with the battery connected, as you say, but not without the battery connected, then leave the battery connected. I have seen the same issue. But since we want the battery connected anyways, just run it as such.

この回答は役に立ちましたか?

スコア 1
コメントを追加

I don’t agree with statement that 17’’ MacBook Pro won’t boot without battery. I have two 17” and one of them is old Santa Rosa model and I’m using it in my summer house without battery for almost 2 years without any problem, so the booting problem lies somewhere else. My guess is not tight connection with mother board and when you place the battery the connection with motherboard is established. Check the flat connection cable, maybe is damage and replace it.

この回答は役に立ちましたか?

スコア 1
コメントを追加

回答を追加する

Gerson Bernardo さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 1

過去 30 日: 1

今までの合計 93