メインコンテンツにスキップ

修理を始めるには

修理する権利

パーツ&ツール

The Asus Republic of Gamers G20 is a small-form-factor gaming PC with enthusiast-level components and good performance.

12の回答 すべてを表示

turns on but no display, also no beep but fans work

My computer turns on, but has no display through my TV. I have concluded that theTV orHDMI plug in is not the PROBLEM! I have took it apart, no dust from what Ive seen but am going in deeper later. I reseted the CMOS, using the jumper. I heard that could help but to only do that for 5-10 seconds. I may of done it for about 15-20 seconds. Did that make my problem worse and if that was the problem and I screwed up fixing it, can I do it again or is it too late? I have ordered a new CMOS battery just in case(cheap). I plan on opening it up more and trying to clean ram sticks possibly, but there wasn't any dust from what I've seen, so I don't think dust would be on the ram sticks, but will most likely still try cleaning it carefully. I have also learned to try unplugging the CMOS battery and reseting it? Or just unplug it and plug it back in? Other than that, I don't know the problem. Theres also no beep as I heard but the GPU and CPU fans work perfectly. So my only explanation is its the ram, or BIOS, with reseting the CMOS would fix right? Do I need to just unplug everything, is it the motherboard in general? What? Its a prebuilt and haven't opened it or anything until recently because of the problems, so I don't think wires are loose either?! Is it just my GPU. I planned on buying a new one around Christmas anyways... so if thats the problem FOR SURE.... its not too bad.. but still help please!

GPU- GTX 760 2GB

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 1

コメント:

No one answered this but if anyone sees this and has a similar question then my answer might help as my computer is now fixed.

So

1. Reset CMOS. Look up videos if needed. Possibly needing to buy a new one.

2. Clean dust in your computer, especially including RAM sticks.

3. My solution was that my computer was 100% operational, but my graphics card was a little messed up. The HDMI plug in for my GPU was messed up apparently from use. So at the moment Im using VGA until I get a new GPU in the future. This could be your problem guys.... try using VGA or getting an adapter to use VGA. VGA will work for me as of right now because all I run is 1080p, and VGA can easily run that.... so don't be scared VGA is crap...... unless your trying to run like 4k or something.

さんによる

コメントを追加

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

1 件の回答

選択されたソリューション

Hi Brett. I think you may have solved your problem, but have you checked to make sure your TV source is set to HDMI? If it is set manually to, say VGA, your graphics output from the HDMI port on your computer will go to the tv and the tv will display nothing. If that does not work, try re-seating your graphics card. Sometimes re-seating the GPU may resolve minor display issues. Worst case scenario, it is also possible that the HDMI cable or HDMI connector on your computer graphics card might be damaged.

Also, just so you know, desktop motherboard bios batteries (Cr2032 button cell batteries) usually last close to 10 years before they need to be replaced. If you ever have this problem in the future, don't bother buying a new cmos battery unless you are restoring a historic computer :D.

この回答は役に立ちましたか?

スコア 2

コメント:

There are multiple HDMI ports on the G20. The HDMI port in the middle, red plate, goes to the motherboard graphics and will not work. unplug it and plug it into the graphics card HDMI port.

さんによる

To start off. I know where the HDMI port is for my GPU and for my MOBO. That has nothing to do with my problem. I have fixed it a while ago. The G20 just overall came faulty IG. Maybe motherboard or GPU problem. Eitherway, my Display Port works for my Monitor and my VGA port works. Just HDMI is a problem. I got the Integrated Graphics to work with HDMI before but sometimes it doesn't... haven't tried in a while, so I have guessed its really just the GPU. Even then I did nothing to it, so its just faulty and may try to return it someday as it still has problems but I have no warranty for it.

さんによる

コメントを追加

回答を追加する

Brett さん、ありがとうございました!
統計データを表示:

過去 24時間: 30

過去 7 日: 158

過去 30 日: 730

今までの合計 17,241