メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

2017年6月8日に発売。A1418 / EMC 3069 / 2017 / 3.0 GHz quad-core i5, 3.4 GHz quad-core i5 or 3.6 GHz quad-core i7 Processor.

122の回答 すべてを表示

USB-C ports are no longer working

I upgraded my computer to 32 GB of RAM and attempted to add a second SATA hard drive. Now the USB-C ports don't seem to work (a second monitor that was working before the upgrade is no longer working). Every other port is working. Are there any USB-C connectors that plug into the logic board somewhere? Any idea what could have gone wrong here? Neither port is working.

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 4

コメント:

I'm having the same issue.

It's weird, it was working but not it's not. (I just brought a brand new iMac 21.5")

Also, I brought a USB-C to USB 3.0 multi adaptor, the both worked for 1-2 days then stopped.

I'm still seeking the answer.

さんによる

I’m experiencing the same issue. I upgraded my iMac to 32GB of RAM and the USB-C ports stopped working. I use practically every combination of new cables to connect to my dual monitor and no luck. Only to find out that the USB-C ports are not functioning any longer. Also, the RAM that I used was from OWC

I wonder how I can address this issue.

さんによる

コメントを追加

3件の回答

選択されたソリューション

Same issue here. I upgraded my 2017 21.5 iMac to 32 GB RAM. Everything fit back into place and works like a charm… except the USB-C ports. I’ve tried all the USB-C cables and adapters I can find. No luck. Do people think this is a problem with the RAM, or is it more likely that I somehow damaged the USB-C ports?

Update (01/15/2019)

I ended up solving the issue. I think there was probably a slight misalignment between the port and the case. When I looked at my computer I saw that it looked a little off. So I stuck a USB-C in and just put pressure on it toward the direction I thought it needed to go. After a few seconds of pressure, I heard a “snap” and then the port started working. I was definitely worried about breaking it, but I figured I had nothing to lose so I just went for it.

この回答は役に立ちましたか?

スコア 2

コメント:

Ha!! THX Man!

You don't even know how !#^&@@ off I was! Terrible!

After upgrading the frame to 32 - these ports stopped working for me. And I just read the comment and I'm talking and playing with the entrance and you were right - something crunched / snapped and started to work. Thanks! :)

さんによる

I had the same problem, i changed my RAM and after that, USB-C didn´t work. So i have tried to put pressure on it and... IT WORKSS.

Scott you saved my life. :) If you come to Spain any time I will you buy a beer, Thanks a lot. And thanks for share.

さんによる

コメントを追加

In my case, the motherboard was badly seated, 3 mm is enough to make the ports fail because the connectors doesn’t go all the way in and it’s very hard to see this problem just by using your eyes, take it apart and take a look at the ports assembly on your MB, you’ll notice a small bump/ball/thing in the middle, this bump has to fit into the iMac ‘case’, you can feel it when seating the MB on the case if you do it right

この回答は役に立ちましたか?

スコア 2
コメントを追加

My iMac (21.5 inch 2017 model, 3.4 GHz) had a fusion drive, and I upgraded the ram to 32 GB and replaced the 1 TB drive with a 500 GB SSD. Using Apple's instructions for fixing a fusion drive (https://support.apple.com/en-us/HT207584), I merged the "blade" drive and the SSD into a new fusion drive. I then restored from a Time-machine backup, and reset the PRAM and SMC.

The USB-C ports did not work with my external display when I used a USB-C to HDMI adapter and cable that had worked before, but when I tried another adapter, the problem was resolved. Both adapters were supposedly exactly same, as I had purchased one for my iMac and one for my laptop (https://www.amazon.ca/ICZI-Aluminum-Thun...), but only one worked. The adapter and cable that you are using to attach to your monitor may be the issue.

この回答は役に立ちましたか?

スコア 1

コメント:

Is the adapter you listed via amazon the one that works? I'm experiencing the same issue after only installing upgraded RAM. Everything else is the same.

さんによる

if your USB-C ports are not working then no adaptor will work. I tired 3 different adaptors even form Apple nothing worked. Was it working before up upgraded? maybe try a different type of RAM.

さんによる

コメントを追加

回答を追加する

jasontpkoebler さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 19

過去 30 日: 71

今までの合計 2,141