メインコンテンツにスキップ

対象のモデルはA1419 / EMC 2806 / Late 2014 または Mid 2015。 3.3 または 3.5GHz Core i5 または 4.0GHz Core i7 (機種ID iMac15,1)、EMC 2834 late 2015 / 3.3 または 3.5 GHz Core i5 または 4.0 GHz Core i7 (機種ID iMac17,1)のRetina 5Kディスプレイを搭載したすべて。

501回答 すべてを表示

Unexpected mains power shutdown

My late 2015 iMac 27 5K developed a fault earlier this year: it started shutting down unexpectedly, initially once or twice a day up to every two to three minutes. I checked the power cord, used different power outlets in different parts of the house, booted in safe mode, checked the syslog file for any error messages which could explain this, no explanation found. Important: after each unexpected shutdown I had to reset the SMC to get the machine to react to the power-on button again.

Took it to the Apple store for a repair. As the machine displayed these unexpected shutdowns while at the store they replaced the logic board and the power supply. Machine worked fine for a few weeks and then started shutting down unexpectedly again. Back to the Apple store again where this time the machine apparently ran fine for one week without any problem.

Back home within two hours started shutting down again, now every two minutes, so unusable. Does anybody have any idea what could make the SMC shut down the machine? Is it a (false) high temperature warning?

Which other part might need replacing?

Could there be another problem causing damage to the logic board and/or power supply?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 9
9 件のコメント

I have a same problem with my iMac 2017 5k 27", already send for diagnose and repair, the repair man diagnose with high processor temperature, they suggest to down grade with i5 7600, after change the problem is still the same, I also thought its a logic board problem, seem like many users here change PSU & LB still facing the same problem after few weeks, I might try UPS

さんによる

I am having this trouble too. Same imac 27 2015 retina. No problems with other equipment. I need to remove power to the imac and reintroduce before it will start up again. Seems like a common issue on the web.

さんによる

You need to check your AC power. I strongly recommend you get a UPS

さんによる

I am having the same issue on my mid-2015. I have a mini Mac on the same power strip and it doesn't have a power shutdown issue.

Of course my warranty is over. What parts would cause this?

さんによる

Sean - Make your sure your power is clean and your house ground is good. I would first move your Mac mini to a different circuit so you can be sure you'er not over loading your line. Dedicate the line for your system and use a good surge suppressor or better yet get a UPS.

If you are still encountering issues I would recommend you visit an Apple Store to have them test your system. There are quite a few possibilities so one can't just tell you its this vs that.

さんによる

4件以上のコメントを表示

コメントを追加

4件の回答

選択されたソリューション

Hello fellow sufferers,

Logging mains showed no abnormalities except em noise in the UHF band when LED lights are switched on. This does not appear to affect mains supply to devices but messes up bandwidth of PowerLAN. My iMac 27 problem was eventually fixed by Apple replacing logic board, PSU and almost all other internal parts in the Apple store. Since then the iMac has been behaving perfectly. My conclusion is that there must be some electronic components in the iMac 27 which can fail leading to the machine shutting down. Nothing else has changed in my house, all other Macs work fine, there are no spikes on the mains, this is an Apple manufacturing problem and it would be nice if Apple could acknowledge this and fix it. Sorry I cannot provide a magic bullet to fix this.

このアンサーは役に立ちましたか?

スコア 1

6 件のコメント:

mine doing same thing. Im sick of it

さんによる

Brought a new 5 month old iMac (Retina 5K, 27-inch, 2020) to apple store and while they were running a test as i sat with Genius, the shutdown replicated. (which the tech noted. ) Repair was supposed to be completed with several new parts yesterday. I went to the store to check status (7 days later) and they’ve only wiped the system clean and reinstalled os, and only running a 24 hr stress test trying again to replicate the problems(again… why???). No parts have been repaired !!!!! even though the tech listed several on my order, and had the system a week! I need my computer since my clients have files we need to access. …..And they’ve only reinstalled os (like i told them Apple tech online had me do 3 times already and didn’t solve a thing. So frustrating!!!!!!!) Ive lost confidence in Apple products and customer support… I feel like they’re yanking my chain and nothings getting accomplished. 7 days just to wipe a system and reinstall os … doesn’t make sense.

さんによる

@C Lamb - Best to locate an independent Mac servicer. Make sure they have the micro soldering skills as I'm sure your logic board likely needs some attention.

さんによる

Maybe this is the same problem as the mbp have.

Delete or move away this file:

/System/Library/Extensions/ AppleThunderboltNHI.kext driver then reboot.

You need to disable "csrutil" (just google it)

Source:

https://forums.macrumors.com/threads/hel...

さんによる

s.heinrich - The MacBook Pro solution really wasn't a solution!

It basically disabled the Thunderbolt ports - No driver, no Thunderbolt ports!

While this is a good last ditch effort when the Thunderbolt chip is blown it really doesn't fix anything! It just allows the system to work without it.

FYI: The issue was not related to the OS release, but the init of the newer OS driver failed at the time of the update which then killed the system.

This system uses a different Thunderbolt chip so I'm not sure if the driver is the same right now as I don't have access to the system to tinker.

But lets say it was a common driver between the Thunderbolt chips then the question comes back to the root issue if the Thunderbolt chip is blown this is only a bandaid not a solution.

さんによる

1以上のコメントを表示

コメントを追加
最も参考になった回答

Did you bring your system to a real Apple Store or an Apple authorized service center?

You'll likely need to verify if the logic board and power supply where truly replaced. From the sounds of it I suspect your power supply and/or the logic board still has a problem.

You might want to also check your home's AC power. Things that can mess you up is bad power coming into your home from your utility as well as poor building grounding. You'll need to get an electrician to check your house wiring and see if you can get a power meter from your local utility.

You also want a good power strip for surge suppression. If you can swing it get a UPS.

このアンサーは役に立ちましたか?

スコア 3

4 件のコメント:

Agree with Dan. Before I got my 1st iMac in Dec. I got learning curve advice from friends who are computer engineers.

* They said iMacs are particularly sensitive to power spikes and wave form and to get a UPS (Uninterrupted Power Supply) before ever turning the iMac on. LoL! I thought UPS was a delivery service.

* Went for a CyberPower Intelligent LCD model (825VA) with "simulated" sine wave only because this was the model they used on their iMac but they use other brands as well.

* Was told I didn't need "pure" sine wave which are considerably more expensive.

* These units are roughly the same price across all brands. The price changes with volts/watts/power you need or if you go for pure sine wave over simulate.

Cheers xoxo :)

=== Update (07/15/2017) ===

Since giving my comment almost one year ago. My 27" iMac I bought in Dec 2016 specs:

* 4 GHz Intel Core i7

* 32 GB 1867 MHz DDR3

* AMD Radeon R9 M395X 4096 MB

Began doing a total freeze (can't exit or close apps using keyboard) Had to use the power button to restart. I would wait for 30 - 60 seconds and it restarts. I figured "whatever" it was just times-out.

Any ideas? It happened mostly when I was touring around using Google maps in chrome. It was in full screen in 3D. With 32 GB RAM I wouldn't think I was overloading it.

Looked in Apple forums and the most logical thing was it could be something from a 3rd party app causing that. Its a common issue with the late 2015 iMacs particularly (from what I've read) with the upgraded processor and Graphics.

Any ideas. I'm under AppleCare for another year and a half. But, they're just going to say delete all 3rd party apps.

Cheers etc

xoxo

さんによる

Hello Kemble, thanks for your comment. Fully with you re UPS. Run all my home stuff off two APC ES 700 UPSs. If the problem is caused by spikes, they either manage to get through the UPS (unlikely) or there are significant EM pulses in my house. I will run a data logger for several weeks to monitor mains and environment.

さんによる

Hans-Georg - Did you get an electrician to check your house wiring (ground)? You could have a bad device plugged in which has a bad power supply messing up the ground (hot). Let us know if they find anything and your loggers output.

さんによる

Thanks Dan, Apparently my comment to your original answer went awry. As I indicated in my other comment, I fully agree with your approach and suggestions. If the logger shows any spikes I will certainly get an electrician to check my mains supply in my house. I know from previous experience in Luxembourg that one device with a bad earth connection can cause a lot of problems. The only doubt I have about the spike theory is that the iMac showed the same type of unexpected shutdowns while I demo-d it to the chap at the Apple store. Will keep you informed about progress once I am back in the UK.

さんによる

コメントを追加

Hi, I don't know if I have the exact same problem but it looks like this. Every time I turn on my iMac, it shuts down during the boot process and restarts. Sometimes up to 10 times in a row. When the login screen is reached and I log in, the iMac also always shuts down within a few seconds to a few minutes. However, if I use this iMac in target display mode (cmd-F2) with another iMac, it no longer shuts down and I can use the iMac all day. If I log in to the iMac and then do nothing with it (no mouse movement and no keyboard), the iMac also stays on. Does anyone know what kind of defect is causing this? And why does the iMac never shut down (reboots randomly) when i use it in target display mode??

FYI the iMac on the left is a newer one with no issues. I usually (after a lot of spontaneous reboots) use the right iMac in target display mode as a second monitor for the left iMac. At 5.25min i perform a PRAM reset twice (without positive result). All reboots in this video recording occur spontaneously.

I also already tested with other RAM modules with no effect. I have this same problem at different places (at home and at work) with properly grounded outlets.

I recorded my issue. You can see it on https://www.youtube.com/watch?v=eF6uiHwC...

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Same issue - 2015 27” imac with i7 processors. Had the Logic Board and PSU replaced but still had issues 2-3 weeks later. Had it sitting on a shelf for the last 18 months. Got it out and wiped the OS drive, reinstalled Mojave, and it ran great for a full month. Now it won’t even get all the way through POST before shutting down again. I have to do an SMC reset just to get it to respond to the power button. I have always run it on a UPS, so no idea what could be causing the issue.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Hans-Georg Wagner さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 14

過去 30 日: 66

今までの合計 11,626