No image on built in display

This Zenbook came with Windows 7 Pro installed. It was upgraded to Windows 10 about 8 months ago, and worked fine for the first 6 months - no issues at all. For the last 6 weeks it was used as a desktop computer with external monitor via the micro HDMI port and the laptop screen switched off using Function+F8 key. Now that I want to use it without the external monitor, I can't get the ultrabook screen to display anything (nothing even when starting up). There's a dim glow from the backlight but no image. Apart from that the thing still works perfectly with an external monitor.

I updated the BIOS to version 219 and the Intel HD 4000 graphics adapter to the latest version from Asus website. I also tried disconnecting the battery to drain the power from the CMOS chip. There hasn't been any accident or rough treatment and the device is 4 years old, not extensively used.

If a hardware problem, then the suspects would be the display panel or the internal cable. I don't know how to check either one.

My guess is that it's a software problem related to using the external monitor or possibly windows updates.

Any ideas?

この質問に回答する 同じ問題があります


スコア 0

2 件のコメント:


Can you do a system restore to a point more than 6 weeks ago? Go to Control Panel > Recovery

If the screen works it proves that it is a software problem.

Do a data backup first (just to be safe -a system restore shouldn't affect your data except that any new programs or updates that have been installed since the restore point date will need to be re-installed. Also create a current system restore point as well


It may be a problem with the back light. Shine a bright light onto the laptop display and see if you can see icons on the screen. It will be hard to see and you will need to angle the light to reflect off of the display to see icons and items on the desktop, objects will be very dim.