メインコンテンツにスキップ

Super Nintendo Entertainment System (SNES)、もしくはスーパーファミコンは16ビットゲーム用コンソールで、1990年に任天堂によって発売されました。スーパーニンテンドーはベストセラーのガジェットの一つで、まだ多くのファンが存在します。

104回答 すべてを表示

L and R buttons not working.

I have had this SNES controller for a long time that's L-button is not working. So I took it apart today, cleaned all the parts and put it back together. But now the R-button doesn't work either! So all the other buttons work great, except L and R buttons. I have no idea what the problem is. I used a multimeter to determine that current gets through the connection when button is being pressed. I see no visible damage to the circuit board or wiring inside the controller. Is there anything I can do to fix this?

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

I opened the controller again and put it back together, and now the R button works again. But the L button doesn't. I did some troubleshooting and I believe all the connections are fine inside the controller. But whatever chip that controls the controller (Mitsumi V520B) doesn't respond to the L button. I guess there's nothing I can do about it, unless someone can tell me where I can find a replacement circuit board for my controller.

さんによる

コメントを追加

1 件の回答

I'm taking a wild stab at this one after looking at the internals of a SNES controller. It appears that the signal transfers through the circuitry after the button is pressed, very similar to how all of the buttons on that controller work.

Open the controller again and take a look at the silicon pad that the L-button presses down on. If that pad is glossy or shiny then it's not making a proper connection. There are at least two ways to clean up the silicon pad:

  1. Take an eraser and lightly rub the shininess away so you get a dull, matte finish. You can even take the eraser and clean up the contact on the board.
  2. Get a sheet of paper and gently drag the silicon pad across it until you get a solid, dark gray streek.

Try those out and see if it brings the L-button back to life.

このアンサーは役に立ちましたか?

スコア 0

コメント:

I have cleaned all the parts the best I could. I don't think the problem is in the connections, because I read a connection using a multimeter. I even used a piece of wire to connect the pins of the chip inside the controller directly to ground. I managed to get all the other buttons to respond this way, except the L button. So I believe the problem is in the chip itself. So probably the only way to fix this would be to replace the chip (it's probably unlikely I would be able to find a spare chip) or the whole circuit board. But this is not a big problem since many games don't utilize the L and R buttons.

さんによる

コメントを追加

回答を追加する

Juha Toikka さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 9

過去 30 日: 22

今までの合計 1,334