メインコンテンツにスキップ

2010年4月発売。2.4, 2.53 GHz Core i5 or 2.66, 2.8 GHz Core i7プロセッサ

579回答 すべてを表示

Display Problem : Green on black color parts on screen

Hi

I have a problem here, anyone can help ? :p

Screen capture if the problem

Video showing the problem

Everything that's black on the screen displays green 'matrix' color.

It happens whether it's using integrated intel card or the dedicated nvidia.

By squeezing / moving the body of the computer the problem can disappear....

Looks like a faulty contact somewhere, i opened it and it seems the problem stops when i push around the right heatsink

I found some stuff around on the web and it seems it's a know probleme but nobody really seems to know what it is, ever heard about this ?

Thanks a lot

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 12

コメント:

I have same problem....any fix's available ?? Thanks

さんによる

Hi def

same problem here in venice, italy :-(

10 days ago my MacBook Pro mid 2010 started to show acid-green instead of pure black.

Have you found any solution?

I changed my main board just 4 months ago and laboratory gave me just 3 moths warranty.

Thank you

Maurizio

さんによる

Did changing the main board take the problem away Maurizio?

さんによる

Same problem here (Venice too!). I have heard that there is a cable replacement available from a China distributor, has anyone tried it? Or any alternative to solve the problem?

さんによる

I´m in Malaga - Spain and i´m having the same problem. I have connected to the HDMI output and working ok ! but if i use minidisplay port to DVI adapter I got the green lines (matrix style) on the dark areas.

さんによる

5件以上のコメントを表示

コメントを追加

13件の回答

選択されたソリューション

FIX!!! - Remove the back cover, upper right corner you'll see the cable wrapped in black paper from the monitor connected to the board. there is a tab wrapped to a mini steel bar, pull up on it unlocking it. Pull back on the cable disconnecting it. Spray the area with air to remove dust/debris. Reconnect the cable. Reinstall the backplate. Turn on, and see no more green where black should be. Glen Poland, Georgia, USA

(My guess is that the dust buildup is semi conductive and 'shorting out' some of the pins/connectors.)

このアンサーは役に立ちましたか?

スコア 13

コメント:

I know connections get loose .. but jinkies that connector was the issue.

さんによる

I just had this problem. For me it was not the screen connection in the main body of the computer but the connection in the "screen part" where the MacBook Pro logo is that came loose over time (I guess from opening and closing). Quick fix for me was I opened screen all the way till I couldn't any more the shut it, did this a few times and viola no more green :) later on I opened up the screen and fixed it properly, the connector had wiggled is way a fair bit out so this would be what I would recommend if the easier (main computer body connection) looks good. You can find info online in regards of how to take apart the screen. I am in no way an expert, I am just telling you what worked for me. Attempt at own risk.

Mike

さんによる

This worked for me! I had already taken it to the Mac store to have it looked at, and they didn't manage to solve the issue and said I'd have to purchase a new graphics cable. So I opened up the back myself with a pointed knife to undo the screws. Blew the dust away, reconnected the cable, and hey-presto, MY SCREEN IS NO LONGER GREEN. Thank you Glen from Georgia!

さんによる

Thanks for these easy to read/follow instructions. You have helped me save time, money and energy! God bless.

さんによる

Tried this and it didn't work for me, any other ideas on how to fix it?

さんによる

7件以上のコメントを表示

コメントを追加

Hi everyone, I had the same problem, I solved this way: as you can see from the image, pressing at that point the problem disappeared, so I inserted a piece of rubber (normal rubber to erase) of 4 mm (thickness) so that closing the rear cover would remain as thick. I solved the problem definitely.

Ciao a tutti, avevo lo stesso problema, ho risolto in questo modo: come potete notare dall'immagine, premendo in quel punto il problema spariva, quindi, ho inserito un pezzo di gomma di 4 mm di spessore (una normale gomma per cancellare) in modo che chiudendo il coperchio posteriore rimanesse come spessore ed ho risolto il problema definitivamente.

Block Image

このアンサーは役に立ちましたか?

スコア 7

コメント:

Cosimo Alberto thanks worked for my macbookpro 2009

さんによる

Thank you Man solved my problem not on the exact same spot but near it what could the problem by there ??

さんによる

I had the same problem with a 2010 15-inch Macbook Pro. I fixed it with this solution using 4mm cork and placed 3 small pieces in a similar area to you. Thanks for the idea!

さんによる

Yep, the 4mm-thick piece of eraser (rubber) between the back cover and motherboard roughly under the Tab key of my Late '08 MBP provided the pressure that did the trick for me. If the problem is caused by the solder melting (and cooling over and over causing degraded contacts) under the failing thermal paste under the graphics card I can't imagine this rubber shim will be a permanent fix; it's working perfectly for now. (Even though it is a Core-2 Duo (2.53GHz) with 8GB RAM, a DIY Fusion drive since 2013 and MacOS 10.11.6 it is a good second machine with quite acceptable response for most tasks.)

さんによる

Same problem with my mackbook pro 15 inches, 2009. Thx to Chistopher Ball! I try your cork trick and it works fine now. THX a lot man.

さんによる

1以上のコメントを表示

コメントを追加

The Apple Display Port to DVI Cable that pulgs into the back of the Mini may not be properly plugged in, or, check out this solution.

If this answer is acceptable please remember to return and mark it.

このアンサーは役に立ちましたか?

スコア 1

コメント:

i'm not sure what you're referring to... are thoses parts inside the computer also ? what you're talking about seems to be outside components to plug an external display and my problem is just on the macbook itself, nothing is plugged.

As for the link you sent, as i said before it's the same using both graphics card

Thx

さんによる

Nvidia cards were know to be problematic.. there was an extend warranty/replacement but that's over. Yes the faulty contact could be a loose or broken connector to the video card inside the case - one that connects the external DVI port to the GPU. Moving the body could torque the cable to either short/not short that connector. The connector may even be damaged inside.

さんによる

コメントを追加

Hi I have the same problem, I took my 17 inch macbook pro 2009 to a local solutions inc store (apple experts) they diagnosed that a replacement display was required at a cost of £600+. I said no thanks and took the macbook home for further investigation. if i plugged the macbook into my iMac and used that as a display no green lines, so I deduced the same as the shop. I bought a new display from Germany at a cost of £85, I replaced the display, turned it on, only the find the the green lines were still there! Next I will replace the display cable...unless anyone else can suggest what could be the problem?

このアンサーは役に立ちましたか?

スコア 0

コメント:

I just did the same, replace the display because mac said was the problem, but after I replaced it myself I still have the same problem.

さんによる

Everyone check your heatsink.

さんによる

コメントを追加

I just had this problem. For me it was not the screen connection in the main body of the computer but the connection in the "screen part" where the MacBook Pro logo is that came loose over time (I guess from opening and closing). Quick fix for me was I opened screen all the way till I couldn't any more the shut it, did this a few times and viola no more green :) later on I opened up the screen and fixed it properly, the connector had wiggled is way a fair bit out so this would be what I would recommend if the easier (main computer body connection) looks good. You can find info online in regards of how to take apart the screen. I am in no way an expert, I am just telling you what worked for me. Attempt at own risk.

Mike

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

I'm experiencing the same problem. I replaced my monitor and the green lines disappeared but were replaced by purple vertical lines all over the screen. Again, they go away when pressure (very small) is applied to the bottom casing (from bottom, just above the trackpad in a MBP 2009)

Did anybody find a solution?

このアンサーは役に立ちましたか?

スコア 0

コメント:

How do I snapped the cable back in? I was able to pull it up and unlock it but I can't find any pictures or anything to help me figure out how to snap it back in. Please help!

さんによる

I followed this instructions for my macbook pro 15", you just have to insert the male end in its socket...

MacBook Unibody Model A1278 LCD Panel Replacement

さんによる

コメントを追加

I finally took it to a Apple store and paid the $300 repair fee so they replaced everything that was bad including battery and I don't have this problem any more. I believe it was graphics card or board.

このアンサーは役に立ちましたか?

スコア 0

コメント:

Did your problem return?

さんによる

コメントを追加

I have the same problem and noticed that it happens when Java is running. If I kill all apps that use Java, the problem goes away. As soon as I fire up anything with Java (Matlab, java control center, visit a page with java code), the green "matrix" dots show up again. When I kill the app, the display is normal.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

It is a common problem within the 2010 - 2013 MacBook Pro 15 and 17 inch - Failing Graphics card.

Actually not so much the graphics card itself, more so the cheap solder underneath.

Once the thermal paste on the GPU gets old and the proper cooling is not given anymore, the graphics card will get quite hot and starts melting. Once it cools down again it starts cracking. and the connection between board and card is interrupted. Results are distorted graphics, no boot at all, lines, reversed colored and plain grey screen, just to name a few.

2 solutions: Have the graphics reflown or replace logic board. The 2011 - 2013 MacBook Pro 15 and 17 are still covered under Apple's Extended repair program until End of 2016.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Hello,

I had tried many things but it only worked when I paid Apple for a $300 warehouse work. They took it in and changed everything that needed to change. Battery and board.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

People have fixed this by cleaning the cable that connects the monitor to the GPU. However my problem was the GPU itself which required the mother board to be replaced. Cost me $300 at Powerbook Medic. I had a warranty claim which was fixed in a week. The GPU is not that robust I think.

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Thanks for the solution with easy steps. https://www.spyfoxx.com/

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

Welp i got this problem on my school chromebook crap

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

DefStunz さん、ありがとうございました!
統計データを表示:

過去 24時間: 20

過去 7 日: 126

過去 30 日: 600

今までの合計 143,201