メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

モデル番号A1311 / Late 2009 / 3.06 or 3.33 GHz Core 2 Duoプロセッサ

318の回答 すべてを表示

Boots up with a black screen

When i boot up my iMac the screen stays black the hard drive is running, makes beeping sound but, screen stays black.

I hooked the iMac to a plasma TV and it worked with no trouble. What is wrong?

This i mac is Model A1311 mid 2010 21.5"

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 10

コメント:

I am having a similar problem except mine has nothing when I hook it up to a external display

さんによる

On a Windows 7 computer, waiting about 15-30 seconds would allow it to boot past this.

さんによる

I have same issue

さんによる

@zvineyard8 hi, i have the same problem as yours! My iMac turns on, gives the boot sound but has no video. Hooked to a TV also does not appear image. did you solve the problem? Was it on the screen elsewhere?

さんによる

hello all I have got the same problem but with my late 2009 iMac emc 2308.

External monitor works without any trouble.

All 3 LEDs are working!

Tried changing the full screen (lcd cable included), power supply, video card, tried various inverters (although these parts I'm not sure it worked). The screen is completely black only sees a beam of light when the system reaches the desktop.

さんによる

コメントを追加

7件の回答

選択されたソリューション

Sounds like your display is having problems. Can you shine a flashlight at an angle at the display and see the faint image of your desktop and icons? If you do that would imply the backlight has died. Either the CFL's or the power inverter has gone. If you don't see the image then you likely have a bad LCD or the LVDS cable has become loose.

この回答は役に立ちましたか?

スコア 3

コメント:

Hi Dan i changed the lcd for a new one still the same black screen with no image. The new screen came with new cables which i used.

さんによる

Are you able to see a faint image on the display at all?

さんによる

No image on the display dan

さんによる

Bummer! You'll need to open it up to check your cable and locate the diagnostic LEDS to see what they tell you. You'll find them just to the right of the memory slots, and sit behind the SATA cable where it comes out of the connector. LED 3 is the important one here.

LED 1 Indicates that trickle voltage from the power supply has been detected. This LED will be ON when the computer is turned off and your power supply is working correctly.

LED 2 Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 Indicates that the computer and the LCD display are communicating. This LED will be ON when the computer is turned on and video signal is being generated.

LED 4 Lights only if the computer detects an over-temperature condition. This LED will be OFF when the computer is turned on and running at the correct temperature.

さんによる

Hi Dan i checked the LEDS All the LEDS worked as they should, but when i turned the computer off after the test. ( after 20 sec LED 1 turned off.)

さんによる

3件以上のコメントを表示

コメントを追加

I have the same issue.(iMac 2011 21.5”)

Symptoms: The last months fans run at full speed. Today morning when I was checking sites in Safari, the whole screen went white and the iMac restarted . After the restart the start sound was ok but the screen black and the fans at full speed.

Restarted many times but the screen always. I checked in the internet from another computer and saw many different causes for black screen.

I tried with external monitor in mini-displayPort and after 1-2 restarts it started on the external monitor

I also tried with this configuration pressing D at the boot to go to diagniostics but nothing was showing on the second monitor.

Then booted with the displayport and searched and found the TG Pro. Running it I saw temperatures around 30-40 deg C and the ODD and CPU fans at more than 4000.

I disassembled the machine and got out the logic board using instructions from ifixit. Sometimes on my pcs I use to repair, if they are old enough and have higher temperatures I change the thermal paste and are working very smoothly.

I did the same thing and changed paste on both the CPU and GPU.

Then after assembling and connecting it to power after some presses of the power button it started normally on the main internal screen and the external monitor as secodnary (ISSUE FIXED :) :) ).

I hope it will help other people.

この回答は役に立ちましたか?

スコア 1

コメント:

Hi Thomas, I have a problem very similar to yours! My iMac model A1311 turns on, gives the boot signal but the screen goes black! It is not possible to see anything ... not even with a light against the screen. The 4 LEDs light up on the logic board, and even if I connect a TV to the Mac's output, no image appears. I would like to ask you a big favor! If your iMac is the same model as mine, and if it is the size of 21.5, could you measure the outputs of the inverter board with a multimeter? Thank you!

follow the link of the plate I'm referring to

https://images.app.goo.gl/FRqc17gtpE8WN9...

さんによる

コメントを追加

Hi guys, did this problem get resolved at all? I'm having the same issue at the moment... all 3 LED's working as they should, but no image at all... please help!

この回答は役に立ちましたか?

スコア 0

コメント:

Are you able to see your desktop via an external display?

さんによる

Thanks for getting back to me, Dan! I have a thunderbolt to HDMI but even in normal circumstances I would have to go in to the system preferences in order to select the thunderbolt in the display options... it doesn't just share automatically as soon as the cable is hooked to the TV. So, as I can't see the screen I won't be able to do so! :( Unless there's a different method!

さんによる

Can you get your hands on a Mini DisplayPort to VGA adapter? And you'll need a VGA display (your TV may offer it as an input option).

Most HDMI sets do send the needed active signal which should enable the system to see the display and automatically enable it. Try altering the input options within the TV to see if that triggers things once you come back to the correct port. Also some adapters may have an issue.

さんによる

cmd + F1 (backlight low) will change display to external TV - same problem here. ok with TV, no LCD image - gray back light

さんによる

コメントを追加

Still having this problem, only my backlight turns on after like 5-10 minutes of waiting so it is not completely broken. Anyone have any idea of how to fix this problem?

この回答は役に立ちましたか?

スコア 0

コメント:

Also curious if anyone else has had success. I have the same issue.

さんによる

コメントを追加

I have got the same problem but with my late 2009 iMac emc 2308.

External monitor works without any trouble.

All 3 LEDs are working!

The backlight works, but no image is displayed.

Do you have any ideas what I can try next?

この回答は役に立ちましたか?

スコア 0

コメント:

Did you get anywhere with this? I have the same issue - backlight is OK, but there is no picture.

If I try another LCD panel it works fine, so the problem is NOT the logicboard, the inverter board, or the LVDS cable, but is something with the LCD panel itself. But does that even have any serviceable parts?

さんによる

コメントを追加

Hi,

I read on internet that issue can occur when thermal sensors is covered by dust.

Maybe that can help.

この回答は役に立ちましたか?

スコア 0

コメント:

Where can I locate the terminal sensor.

さんによる

Does anyone knows how to fix this, I have exact issue

さんによる

Urgent help needed. I bought new LOGIC BOARD, for IMac 27, late 2012, I followed the ifixit video instruction exactly as showed, and I replaced my BOARD with new one and after fixing I turned on my iMac and heard the Chem, but it stays on black screen I don't really know what's wrong can anyone give me a clear reason for this please.

さんによる

コメントを追加

I have similar issue too. Mine is imac 21.5, late 2015 model. The screen went black but the external was ok. But I restarted the computer and the screen went black. It makes start sound in the beginning, but the screen is completely black. Need some help please.

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

john v さん、ありがとうございました!
統計データを表示:

過去 24時間: 14

過去 7 日: 91

過去 30 日: 390

今までの合計 33,632