メインコンテンツにスキップ

Fix Your Stuff

Right to Repair

Parts & Tools

One USB port works, one doesn't

One USB port works, one doesn't.

What is likely wrong and how can I fix it?

--Kenoli

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

What are you trying to use on these ports and does it draw power?

さんによる

Hmmm... Did you spill anything on it ever? do any repairs recently? Drop it? anything else notable?

さんによる

コメントを追加

3件の回答

最も参考になった回答

I'm gonna agree with Mayer's diagnosis: on these computers devices that require shadow power from the USB port (if they have an optional dedicated power outlet that is not being utilized) the USB port on the left side (the same side as the magsafe adapter) is probably the one that is going to work.

In the unlikely case that it not a shadow power issue, a faulty USB cable MIGHT explain it, but my money's on USB power.

この回答は役に立ちましたか?

スコア 4

コメント:

+ Derek, very good

さんによる

Got some confirming and some contradictory information related to your diagnosis, which I appreciate and hadn't considered.

Confirming info: A USB mouse does work through the right port while the drives requiring shadow power does not.

Contradictory: Two different hard drives, each of which requires shadow power, work on the right USB port of my partners identical MacBook Pro, while it does not work on mine. Same with two different flash drives. Nothing else is plugged in and drawing power from any other port on either machine.

Seems the right USB port is simply providing no power, though I would expect the mouse that does work to require at lease some small amount of power, which would suggest it is providing some power to the mouse.

Any more thoughts???

--Kenoli

さんによる

Kenoli: seems strange they would work on another system, unless they are identical outside and have different internal components? I remember reading specifically in user manuals for Rane Serato and Protools Mbox audio processors that they only support the left USB port on the A1260 MBP. However, it seems that your partner's machine is performing above expected behavior while yours is behaving as expected.

さんによる

So you're saying that the right USB port is not designed to power devices like hard drives and the port on my partner's machine is a fluke?

Is there any reset similar to resetting the pram or power module that might reset something my machine so it behaves like my partners?

--Kenoli

さんによる

The likely explanation is that the join on your USB port is damaged at the board.., if that's true only re-soldering the joint (IMnsHO not a DIY solution - requires special tools, solder, skills) or replacing the board will fix the problem

さんによる

コメントを追加

Thanks. I presumed something like this. It's not the end of the world and certainly not the cost of a new logic board.

--Kenoli

この回答は役に立ちましたか?

スコア 0
コメントを追加

In my case it was usb-c cable (1meter) it worked on the left, but not on the right side of MBP 2015, different cable worked (shorter)

この回答は役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

kenoli さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 1

今までの合計 5,122