500 watt Aukey Portable Power Station won't charge via any input

I have a Aukey PowerZeus 500 power station — a 500 watt lithium-ion electric "generator" device. When I got it, I couldn't get it to charge. It turned on, and I could power devices off the small amount of electricity that it shipped with in the cells, but no matter what way i tried to power it, it wouldn't register an input and eventually drained to zero.

Aukey sent me a replacement charger, but it didn't change anything. So they sent me a new unit, but declined having me send this one back (I assume they didn't want to deal with shipping lithium batteries a second time). The new one worked fine.

So now I have two units, a good one and a bad one. And the bad one has been sitting in the closet for a while now. It's as big as a toaster oven.

I've wondered if this is something that might be worth looking at internally. Could it be a simple fix? My instinct says no, hence it still sitting intact. But I am not sure what else I might do with this. Send it to e-waste? Any thoughts?

この質問に回答する 同じ問題があります


スコア 0