メインコンテンツにスキップ

Slimblade Trackball suddenly completely dead - how to troubleshoot?

I own a Kensington Slimblade Trackball. It suddenly stopped working completely: mouse pointer doesn't move when moving the ball, buttons are dead. Also no clicking tick-tick sound anymore when doing the scrolling motion. Completely dead. I want to repair this trackball. I do not know how to go about troubleshooting and isolating the error, any advice, guides?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

1 件の回答

ベストアンサー

Hi,

Have you proved that the USB port in the computer that the trackball is connected to is working OK e.g. connect another USB device to the same USB port and check if it works OK?

Have you tried using the trackball in another known working USB port on the computer and checked if it worked OK or not?

If the problem is in the trackball, do you have a DMM (digital multimeter) and know how to use it?

You would need to open the trackball so that you can gain access to the motherboard. Here's a video that may help.

Once open the first thing to test would be if the two wires (red & black) used in the USB cable for the power supply have continuity from the USB plug to where they're connected onto the motherboard.

Here's an image that shows where the wires are connected to in a USB plug.

Block Image

(click on image)

If the cable is OK (also prove that both data wires i.e. white and green wires are OK as well), visually inspect the motherboard for any obvious problems e.g. overheated components, dry solder joints etc.

If nothing is obvious it will be harder to find out what's wrong as the schematics for the trackball would be required (I couldn't find any) otherwise you may have to do point to point testing of the power supply path in the trackball to find out

このアンサーは役に立ちましたか?

スコア 2
コメントを追加

回答を追加する

Anton Kratz さん、ありがとうございました!
統計データ:

過去 24時間: 0

過去 7 日: 3

過去 30 日: 44

今までの合計 402