No signs of life after flashing EFI chip

I got an eBay macbook pro and the seller stated only the backlight was bad. I had a spare display sitting around so I figured it would be an easy way to put together myself a working 17 inch.

When I got it, I had discovered there was also an EFI password on it. Unable to return it, I wanted to try to reclaim the situation, and I followed this guide:

Everything went well from reading the chip to writing the modified firmware back on. Once I reconnected everything, I plugged the charger in, and NOTHING! UGH

No light on the charger (tried a few now), no lights on the battery level indicator, no signs of life when trying to power it on.

I tried a spare magsafe board and no change. All of the small components around the EFI chip are still present.

Did applying 3.3v to the efi chip without removing it from the board fry something, or did I somehow knacker something else? I figured since the guides I saw online still had the chip on the board, I would be fine doing the same.

I have no idea where to start : (

この質問に回答する 同じ問題があります


スコア 0