Side buttons working in recovery mode but not when android boots

Hi, I’m working at a repair center and I’m facing a very bizarre issue. After replacing the data/charging and mic board, everything was fine, phone charging normally (that was the issue that the customer came in with). I powered up the device using the power button and it worked but the surprise came after i locked the screen. The power button works to lock the screen but when i press it, it doesn’t turn the screen back on. When the screen is on after a forced restart the buttons are working, if i want to take a screenshot it works, if i long press the power button it shows the restart and shutdown menu, but no volume controls, weirdly, as i said, the screenshot function works (volume down + power button). In recovery mode the buttons are working fine. I tried to factory reset the phone and it didn’t solve my issue. I’m asking you as i’m getting my head wrapped around this problem and i can’t find any solution. Thanks in advance

この質問に回答する 同じ問題があります


スコア 0