メインコンテンツにスキップ

1.4GHz/1.6GHzプロセッサー、64GB/128GB のSSD

157回答 すべてを表示

Trackpad stops working after 15 minutes

Just replaced my trackpad with one from Ifixit. Now the trackpad works great for about the first 15-20 minutes, then it stops responding completely. After another 5 minutes or so, the cursor starts moving all over the screen and clicking by itself without me moving it. Any thoughts? Might I have damaged the trackpad cable? I was thinking if I did, it wouldn’t work at all, but it works fine for the first 15-20 minutes.

Did a little more troubleshooting. Seems that it happens anytime I click near the left side of the track pad in order to click an icon or to click and drag an icon..

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

1 件の回答

選択されたソリューション

Carefully loosen the screws holding the battery, did that help?

このアンサーは役に立ちましたか?

スコア 1

4 件のコメント:

Loosened the screws a little and then all the way. It helped a little bit. Pointer still doesn’t always respond. Clicker works but cursor movement is very erratic and sometimes not at all.

さんによる

@brodeurman1 - OK that implies the battery has swelled up pressing on the trackpad and/or the trackpad cable.

Take the battery fully out. Press the power button to fully discharge the logic board now plug in the MagSafe the system should spontaneously startup. Does the trackpad work better now?

If not you'll need a new trackpad and cable follow this guide MacBook Air 11" Late 2010トラックパッドの交換

MacBook Air 11" (Late 2010) Trackpad

MacBook Air 11" (Late 2010) Trackpad Cable

さんによる

Did all that. Took battery out, pressed power button, then connected the power cord. Computer didn’t start up on it’s own. I pressed power button to start up. With battery out of the computer and on external power, there is no change. Moving around the pointer is still jumpy and sometimes doesn’t move at all. This is already a new trackpad that I put in a couple of days ago. I’m going to assume that I damaged the trackpad cable. I have one on order. Hopefully that will be the fix. Guess it could be a defective trackpad from iFixit also?

Thanks for the info so far! I’ll post my results once I get the new cable.

さんによる

Put new cable in today. Same issue. Then I took the battery out and powered up with the MagSafe only. Worked great. This battery was replaced about 2 years ago, so I put the old battery back in and it is working fine. The other battery must have been really swelled. I'm concluding that I must have damaged the original cable when I swapped out the trackpad. For all I know, I may not have needed a trackpad in the first place.

さんによる

コメントを追加

回答を追加する

brodeurman1 さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 3

過去 30 日: 19

今までの合計 575