メインコンテンツにスキップ

モデル番号A1706/EMC 3017ー2016年11月発売。この13インチのMac Book ProはOLED Touch Bar搭載です。デュアルコア"Skylake" Intel Core i5 CPUと4つのThunderbolt 3ポートが特長です。

220回答 すべてを表示

Why is the right fan running at full speed after replacing battery.

I replaced the battery in my MacBook Pro 13” Touch Bar Late 2016 using the iFixit battery replacement kit. After the battery was replaced, the right fan started running at full speed (approx. 8600 rpm). I rechecked all of the connections inside the computer including the touch bar connection as suggested, and the fan still continues to run. I downloaded two different fan control software applications, and am unable to control the fan speed. When I checked the computer’s hardware using the Apple hardware diagnostic application, it reported a reference code PPF004, indicating that there may be problems with the fan. I would appreciate any recommendations that you may have.

Update (10/22/2020)

Any new ideas regarding my fan problems?

回答がありました! 回答を表示 同じ問題があります

この質問は役に立ちましたか?

スコア 2
コメントを追加

2件の回答

選択されたソリューション

PPF004 - is a fan error

Inspect the fans ribbon cable for damage, the Tach logic is not communicating to the logic board or the fan its self is damaged.

このアンサーは役に立ちましたか?

スコア 3

15 件のコメント:

I will inspect the ribbon cables from the fans although I did not touch them during the installation of the batteries. Could the problem be related to anything other than damaged cables?

さんによる

さんによる

I sure did, and i didn't touch anything having to do with the fans or the ribbon cables. I am wondering if the non-apple batteries provided in the repair kit are causing this issue.

さんによる

@stevendbotts - The PPF004 error is exclusive to your fan, the battery has no bearing here. If you followed the guide you do remove the logic board which requires disconnecting the fans.

さんによる

Hi Dan, after receiving your comment, I was in doubt, so I completely disassembled my computer once again. I removed the logic board, and confirmed that the fans don't require disconnection. I checked the connections on both fans and confirmed they were connected properly. I have a MacBook Pro late 2016 with the touch bar and retina display. When I assembled the computer and powered it up, I had the same issue with the right fan running full speed. Do you have any other ideas?

さんによる

10件以上のコメントを表示

コメントを追加

Sorry for maybe being too obvious, but I didn't find it mentioned here, so I'll just say it - did you reset SMC and PRAM/NVRAM after reassembly?

If not - check it just to be on the safe side. Here's how:

https://support.apple.com/en-us/HT201065

このアンサーは役に立ちましたか?

スコア 0
コメントを追加

回答を追加する

Steve Botts さん、ありがとうございました!
統計データを表示:

過去 24時間: 2

過去 7 日: 10

過去 30 日: 65

今までの合計 614