Weird ear speaker problem on iPhone XS

Hi, I appreciate any answers that I get as I’m clueless what to do next. I’m not sure if the phone has just been like this but the ear speaker doesn’t work. There have been repairs done to the phone but only back glass and putting a refurbished screen on it (original). I have found that when the loudspeaker at the bottom isn’t connected the earspeaker works. When it’s connected the earspeaker doesn’t work. The connector for the ear speaker did have some damage from prying but I ben it back so there was no metal touching the connector. I have no idea what to do next as I need both to work not just one!

Thanks

Update (06/24/2020)

Block Image

Here is an image of the connector. It was damaged on one side there I have used a spudger to disconnect it multiple times. The corner was bent back a little and I bent it back and covered with green UV paste to stop any unwanted connection from happening

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Can you post pictures of the damage to the ear speaker connector?

さんによる

Thanks for the reply, yeah will do that in a minute. I have done some further testing and after factory resetting the phone both speakers work however after increasing the volume on the loudspeaker the ear speaker dies. After it letting sit for a minute I launch youtube and both speakers work for 1 second and then ear speaker dies again. I'm suspecting a motherboard problem at this point and don't think its the connector but I don't know now. Really appreciate the help

さんによる

コメントを追加