メインコンテンツにスキップ

修理を始めるには

修理する権利

ストア

大きめのアップルMacBook Airラップトップはデュアルマイクと802.11ac Wi-Fi接続を特徴としています。

433の回答 すべてを表示

MagSafe indicator light off

Hi,

There have been no liquid spills as far as I know. The macbook was previously running without any issues, but turned off immediately when disconnected from the power. The MagSafe indicator was lit up at this point. I opened it up and it turned out the battery connector and 2 adjacent wires were unplugged from the main board. I plugged them all in and put the macbook back together.

Now the MagSafe indicator light doesn’t light up at all and the macbook hasn’t booted up since. There are no signs of life (no fans, no warmth, no LEDs). I know it’s not a problem with the adapter, as it works fine with another MacBook in the house.

I’ve tried:

  • Disconnecting the 3 wires again
  • Leaving the power cable plugged in for a few hours then trying to boot
  • Disconnecting just the battery
  • Cleaning the MagSafe port on the laptop

I think it might need a new I/O board but I am not sure. I’d appreciate any help.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

2件の回答

最も参考になった回答

Do you use the genuine Apple Magsafe 45W charger or the chinese replica ? Did you connect the battery before the other cables ? Yes it could be the I/O board or the flat cable that connect the a I/O board to the logic board or a damaged charging circuitry (U7000 IC, SMC, etc). You should check carefully all the cables and connectors, remove the logic board and the I/O board from the chassis and inspect them both sides for any sign of corrosion or damage to the components. It helps to have spare known working parts to troubleshoot this kind of issue.

この回答は役に立ちましたか?

スコア 2

コメント:

It's a genuine charger. I connected the battery last. I will try looking at the connectors and let you know if I notice anything that looks off. I think I might try replacing the I/O board and hope for the best. I'll reply if this works.

さんによる

コメントを追加

It sounds out your skill set to diagnosis this issue. I would recommend you send it to a repair shop. I would recommend Louis rossmann from the rossmanngroup.com they are one of the best and a lot cheaper than Apple and they should have not problem repairing it as long as someone hasn't tried soldering on it already.

Update (05/18/2020)

No problem. Please let me know if it works.

この回答は役に立ちましたか?

スコア 1

コメント:

Yeah, it pretty much is. I’ve built computers before and reinstalled a few laptop hard drives, but I’ve got no idea at all what is wrong with this. My only concern with repair companies is the time and cost of shipping the laptop (I am also from the UK, but Louis Rossmann seems very fair). I might look for a good local repair shop, but most are closed at the moment. I’m definitely considering this, but as more of a last resort (after trying to tackle this myself). If you or anyone else has any ideas of what I can to do diagnose and even fix the issue, I would really appreciate it.

さんによる

I have just received parts from hongkong and my mom just received her new iPhone from China and it took less than a week to arrive. He is located in NYC so they won't be shipping across the country. I know he has received packages from around the world for repairs. I hope you can get it fixed.

さんによる

@barriphone I think I will try replacing the I/O board. If that doesn't fix it, I will go with the repair company you recommended. Thanks for your help. I'll keep you posted.

さんによる

コメントを追加

回答を追加する

Billy さん、ありがとうございました!
統計データを表示:

過去 24時間: 1

過去 7 日: 1

過去 30 日: 3

今までの合計 36