Canon Pixma iP5300 not powering on

I’ve recently tried putting my Canon Pixma IP5300 printer back into action after it spent about 5 years in storage while I was living abroad. Now, it simply won’t power on. The first time I plugged it in since the green power light turned on *briefly* for about one second. Then it turned off and since then nothing happens when I press the power button.

I’ve tested the power cable on a different device (and also tried a different cable on the printer) and this does not seem to be the issue.

Any ideas what the next steps should be to identify the source of the problem?

Many thanks for your help.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

So I found this thread:

https://www.techspot.com/community/topic...

explaining how to remove the power supply (part number K30268) on similar Canon models, which I thought I’d check first. This power supply has five pins that are labeled 5, 4, 3, 2 and ST on the connector. I’ve checked the voltages on these with a multimeter, and they are:

5: 10V

4: -

3: 7.5V

2: -

ST: -

According to people in the above thread, this is fine - the voltages will go up to the intended levels once the power supply unit receives a signal from the logic board.

So I am wondering whether it is the logic board that is at fault here. But is there any way to check that without swapping in a new logic board? Not to mention that obtaining a replacement part sounds pretty impossible with a printer that is almost 15 years old.

さんによる

コメントを追加