Automatic repair couldn't complete

Hi, I bought new Razer P6689 and unboxing it. Tried to tun it on first time, but, it displays that ‘Automatic Repairing’, then goes to next screen ‘Diogonising Repair’ then ‘Couldn’t complete repair. I have tried the other option available i.e. advance option- restore, start up repair, reset etc but no joy. I am frustated that it is brand new and just trying to set it up. I am thinking to return it, unless i can find some solution by tomorrow morning from this forum.

I have unplugged, battery out and in again. When plugged in to the wall AC power, I can power it on but i cannot see the battery light on, only power light AC and wifi light on. Thank you all in advance.

この質問に回答する 同じ問題があります


スコア 0

3 件のコメント:

its brand need to put up with this nonsense, even if you could repair it, may just be the start of many problems. return it to where you bought it and let them figure it out.

with that being said, since you have already tried a restore point, i would open the recovery menu (f8 at boot) and open up the command line option. type in sfc /scannow this will attempt to repair any corrupted system files. if this fails, you could try to do a smart disk check/ hardware check to see if the drive may be failing. if the drive is good and the system file repair option doesnt work, may have to do a fresh install of windows. there should be a recovery partition built into the system, but at this point, i would just return it. hope this helps


Hi jostewcrew, thank you for the answer, i will try f8 and comd prompt sfc... and let you all know.. thanks.


not working... i am returuning it tomorrow. thank you for advice. much appriciated.