X in battery icon in menu bar. What's up with that?

On the above machine, now I get an X in the battery icon instead of an outlet or thunderbolt. I tried another battery on it. The swap showed the thunderbolt for a little while and then went back to the X.

I don't think that it is the battery since it happened to two batteries at the same time. My guess is that it could be the DC to DC board. BTW, the power adapter is glowing green.

Any suggestions to fix this problem?

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 1

コメント:

Thank you for the replies! much appreciated!

I went ahead tried the second battery again. It started to charge and then stopped at 65% and went to an outlet icon in the battery icon in the menu.

I rebooted the machine to get into the charge cycle. However, instead of it charging after the reboot, the second battery too had the X in the battery icon.

I went online and looked at a couple of web pages that discussed the problem. One of the suggestions, was to FLEX the battery area that (for lack of a better word) holds the battery in the computer. After I did this, the machine started to charge the battery. However, it went back to the X after charging it to 65%.

I had yet another battery. I once again flexed the battery area and put in the third battery. I was able to get this battery to recharge from whatever percentage it was on to 100%. I guess the combination of the flexing of the battery compartment and a conditioned battery did the trick.

による

Glad you got it fixed Yuri. Please post your comment as an answer and "Accept" your own answer this way it can be archived and might help the next person with the same issue. Thanks.

による

Well, I thought that I had it fixed! However, since the last post, I had the same issue with it again. I even went ahead and changed the DC to DC board on it. Again, it started to give me a percentage and then went back to the X icon in the battery menu. So, it stands this way, now ALL my batteries show an X when I put them in and also, I changed the DC to DC board at least twice! I am going to try another DC to DC board. Any thoughts on what I can do to diagnosis this problem?

による

コメントを追加

Pro Tech ツールキットを含むご注文、もしくは総額 $100ドル以上のご注文については送料無料です。

当社のショップを閲覧する

2回答

選択されたソリューション

It's either a strange coincidence that both batteries are bad, or your DC In board might need to be replaced. I would try to obtain another battery which you know for certain is in working order and test with that. If you get the "X" again, then replace the DC in board. Does the machine boot without the battery and just the power supply plugged in? Remove the battery and boot with power supply only and chime back in and let me know the results.

この回答は役に立ちましたか?

スコア 2

コメント:

works without battery inside. I am still having this problem with the X icon in the menu bar. when I boot the machine without the battery inside the machine, the X is still in the menu bar.

による

コメントを追加
最も参考になった回答

You can easily check the output voltages on the connecting pins in the battery compartment using a multimeter. The two outer pins are ground, the inner ones should read something around 3,5 volts each. Be careful not to short anything.

この回答は役に立ちましたか?

スコア 3
コメントを追加

回答を追加する

Yuri さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 1

今までの合計 820