I Can't update my MacBook firmware

Here is my very sad story. I have a Macbook pro 13" retina early 2015 (MB 12,1). My bootrom version is MBP121.0167.B07 and according to this ( ++https://docs.google.com/spreadsheets/d/1... ) table I'm running a veeery old firmware, updated to yosemite.

I found this problem while I tried to upgrade to mojave (I'm runnig Sierra 10.12.6). Error while verifying the firmware. After many tries and repairs to the disk, I found the problem: my firmware.

So i tried many thing to update it. Install mojave on a external drive didn't help (same firmware error). I tried to boot with mojave using carbon clone (I cloned the hard drive from my girlfriend's macbook updated to mojave). I also tried to do a update while in mojave, but nothing.

I tried a fresh install of sierra, but no firmware updates. I tried to use El Capitan from a external drive, still nothing.

I tried to install it manually with bless command. The output was good, it sets the nvram to install the update after the reboot but nothing.

Internet recovery bring me to yosemite installer, my internal SSD is not even listed so i tried to install it on a external drive. No firmware update and still can’t install everything else but Sierra (without news about the firmware).

What should I do? Change the logic-board seems expensive and stupid if the problem is just a upgrade.

Under storage I see Device Name: APPLE SSD SM0512L it should be a original apple ssd.

Thanks everyone.

この質問に回答する 同じ問題があります


スコア 0