メインコンテンツにスキップ

対象のモデルはA1419 / EMC 2806 / Late 2014 または Mid 2015。 3.3 または 3.5GHz Core i5 または 4.0GHz Core i7 (機種ID iMac15,1)、EMC 2834 late 2015 / 3.3 または 3.5 GHz Core i5 または 4.0 GHz Core i7 (機種ID iMac17,1)のRetina 5Kディスプレイを搭載したすべて。

259の回答 すべて表示

Random flickering screen - does seem to 'fix' on reboot

I've done some research and it seems more people have the same issue.

This video ain't mine (so far my issue ain't that bad only similar):

https://www.youtube.com/watch?v=AWW9bt1T...

It can go days with no issues and then it happens usually starts when I'm scrolling through my mails on Outlook and when it does start even checking my apps on the dock (Dock's amplifier effect) triggers it as well.

Then I reboot and all is well for days…

What is that? Could it be faulty cable or a software issue maybe a firmware thing or even something with Mojave's Metal…?

Oh and I've seen the copy/paste reply sent to others online saying ‘replace display here's the guide’. That's not what I'm after.

First those displays are almost as expensive as the iMac itself but also other than this random flickering it works fine there has to be an answer other than the usual Apple motto ‘pay heaps of cash to replace or a truckload of money to buy brand new’.

This is iFixit, doesn't anyone knows how to fix this…?

Update (07/14/2019)

After reading on MS forums many more people having issues with Outlook flickering screen on Mojave I downgraded mine to a previous version.

Actually tried as far back as 2011 but that wouldn't read my files and 2016 wouldn't even run on Mojave (all other Office 2016 apps would though) so I reinstalled Office 2019 and left it un-updated.

Current Outlook version is 16.19 will see if it still happens or not and keep this here updated.

Also gonna do the ‘heat management’ thing mentioned below anyway. Just gonna take a bit longer so the 'downgrading test’ still holds value I think…

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Ok so this just happened after about a month without issues: was scrolling Outlook and started to flicker so I closed the app and started to scroll my files on Finder.

On Finder nothing happened but when un-hiding the Dock and magnifying its icons it was flickering but much less than with Outlook.

So I opened Outlook again and scrolled once more. This time before flickering I got beach ball for an instant and then the flickering resumed - that was really odd!

So I rebooted and now it's fine again… What the heck…?

による

コメントを追加

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

2回答

最も参考になった回答

Sadly you’re not going to like my answer either ;-{ Your display assembly has failed, you need a new display.

OK I get it… What!! What could be going on to do this!! WHY, WHY!!!

OK, heres the dope!

Your display has a logic board on it which is called a T-CON it drives the LCD panel X & Y lines that energies the given pixels row by row, column by column! So when it messes up you get the fireworks you saw on in the video. Its also possible to damage it if you don’t use the proper tools taking the display off.

Block Image

Review the iFixit teardown here iMac Intel 27" Retina 5K Display Teardown Jump down to Step 6 for more details

この回答は役に立ちましたか?

スコア 2

コメント:

But why is it that it is fine for days and suddenly start flickering (like I said usually scrolling Outlook emails) then it's fine again after reboot? And it will keep going for days, weeks maybe, only to start again out of nowhere…

Could it be one of those chips highlighted on the T-CON board (step 6) is faulty…?

による

It could be a bad chip, capacitor or solder joint. The alteration of the pixels as you scroll the image or heat could set it off.

This is not really a serviceable part as the display ribbon cables are welded to it so you can't take it off to work on it. Trying to solder or even applying a heat gun will damage the display under it.

による

I was also thinking heat could be the issue specially since those units don't have vents on top like older models…

Well if replacement is the only other option then I don't really have much to lose so I'll try to glue some copper shims on those chips and see what happens…

による

The heat would be from the LED backlights which is just behind the board. I don't see adding any copper will change things don't forget the metal cover is just above I could see using some thermal pads filling the gap between the chip and the cover (just snug ,not pressing) as a better solution if that was the issue.

As for the systems cooling design it uses a pull fan unlike the older models which exhausts out the back which is more powerful than the chimney effect the older models used (more CFM's).

による

Yeah I've been encoding videos the past 2 days and nothing… will switch off dark mode and see what happens then…

The thing with getting something between the board and cover is I don't want anything pressing anything: if there is room for shims I'll do it otherwise I won't (ones I have are 15mm square by 0,3mm). I do have thermal pads as well and that could be an alternative thanks :)

による

表示する 4 他のコメントを

コメントを追加

Mine does the same thing when I scroll through my Outlook. Reboot and it’s fine

この回答は役に立ちましたか?

スコア 1

コメント:

Only Outlook as well? Weird…

による

コメントを追加

回答を追加する

Carlos Ferrari さん、ありがとうございました!
統計データを表示:

過去 24時間: 2

過去 7 日: 13

過去 30 日: 50

今までの合計 86