メインコンテンツにスキップ

モデル番号A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5もしくは 3.4 GHz Core i7 Processor, ID iMac12,2

503の回答 すべて表示

Black screen after display fell out of case

So what happened was the display fell out while in use. I guess it wasn’t secured by the previous repair guy. What happened after it all got plugged back in was no power and no chime. I took a look at 2 connectors had been torn slightly, but enough the cable didn’t sit all the way in.

So I started with replacing the logic board because I don’t have experience soldering board components. I then got a chime and the computer to start. However it was stuck with a black screen.

I also plugged it into an external monitor. The main screen showed up, but it acted as if it was a secondary monitor so all I could see was the background and top navigation.

I then tried to replace the LED back-light inverter board. Replaced it, turned it on and same issue.

Then I tried replacing the display cable (because it looks like it’s the only cable you can swap out) and still same issue.

I’m avoiding having to replace the entire display, but it looks to me like it I might have to as something else might have been damaged I don’t see. I’m not against replacing it, but the screen didn’t fall very fall, just enough to pull the cables out of the connectors. So it didn’t seem like it might have done damage. If anyone has any advice on what I should try next I would appreciate it. Thanks.

Edit: Here's a picture of the bottom. The screen falling out is not the issue right now. I have replacement screws to keep the screen in place once I fix it.

Block Image

My issue is that I get a black screen when I boot it up. I hear the startup chime just fine and am external monitor works. Not the screen falling out.

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 0

コメント:

Are you sure you have the correct model listed here? The 2011 model uses magnets on the cover glass and the LCD panel is screwed to the chassis!

The 2012 'Thin' Series uses adhesive tapes which secures the unitized cover glass LCD panel into one part. A common issue is failure to clean the surfaces completely and properly prepping the surfaces (leaving oily residue) or worse yet! Thinking the old tape is still sticky enough and tries to use them! Which it is not.

による

Look on the bottom of the stand for information on your model. If you plug the serial number in here to tell exactly what it is

https://everymac.com/ultimate-mac-lookup...

による

OK you do have a 2011 27" !!

Your systems specs: 27" iMac i7 3.4 GHz 3.4 (Mid-2011)

による

I know that I have a 27" iMac from mid 2011. I need assistance with the black screen I'm getting when I power it on. I get the startup chime and an external monitor will work. I can't figure out what's broke that it shows a black screen.

による

I'm just shocked someone would forget the screws!

Even if they had put in one or two things would have been so much better! Clearly this person is not skilled and should be reported to your better business bureau.

による

表示する 1 他のコメントを

コメントを追加

iPhoneのバッテリーキット

Only $29.99

Buy Now

iPhoneのバッテリーキット

Only $29.99

Buy Now

1回答

So the person who worked on the system before who forgot the screws holding the LCD.

I would tell your customer they need to go back to the original servicer and get the screws and get his money back as this is a train wreck!

この回答は役に立ちましたか?

スコア 0

コメント:

So there's nothing I can do? It's finished? I'm trying to help them. If they want to go get their money that's their issue. I just want to get it working for them.

による

The problem is you have a black hole here.

I'm sure its fixable but the cost will likely be a new display and the logic board may need repairing (the display connector) or just replacing the logic board.

We just don't know whats damaged on the logic board either from being pulled at and what the previous person did.

As much as I love this model (I own one my self) there is a point of spending too much.

による

OK. Thank you. I did replace the entire logic board and it didn't fix the issue. I also tried replacing the inverter board as well which did nothing. I saw that displays ran in the 100s but didn't know if I missed something else. I'll let them know it's a lost cause. Thanks for the help.

による

コメントを追加

回答を追加する

Repair-IT さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 34

今までの合計 34