メインコンテンツにスキップ

Repair guides and support for the autonomous Roomba vacuum cleaning robots by iRobot.

163の回答 すべて表示

IRobot Roomba 620 wheel

I have a iRobot Roomba 620. I turned it on one day and it wheeled around in a big circle. After about 30 sec. it says, “error 10, spin wheels etc”. I did that, nothing. I order brand new wheels components, put them in, reset by holding down the “spot & dock” buttons.

I took the new wheels out again and I noticed both spun the same until I put them in. The left on is a bit stiffer. You can hear it too when the motor turns. The free-er one has a higher motor sound.

This is where I am stumped. Circuit board?

この質問に回答する 同じ問題があります

この質問は役に立ちましたか?

スコア 1
コメントを追加

1回答

最も参考になった回答

@cbenish try a few things first based on this “both spun the same until I put them in. The left on is a bit stiffer.  “

Check the wheels for obstructions.

Push the wheels up and down several times and shake out any loose debris that may be trapped in the wheel well.

Make sure the wheels turn freely.

The other thing to consider is dirt/grime at the optical encoders that sense wheel motion. Take a look at those and clean those with some isopropyl alcohol. Last but not least, you can also check the drive motor on the module.

There are two wires, a Red and a Black one that connect to the motor. Find those two wires on the connector that plugs into the connector on the main board, apply power form a 9V battery to those wires, the motor should turn in one direction. than reverse the wires, and the motor should turn into the opposite direction. If it does you may have a bad component, either a diode or a power transistor (pretty common) on the H Bridge.

Let us know what you find

この回答は役に立ちましたか?

スコア 2
コメントを追加

回答を追加する

cbenish さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 0

過去 30 日: 3

今までの合計 28