Skip to main content

Repair guides and support information for televisions manufactured by RCA.

69の回答 すべて表示

My RCA 65 inch smart TV doesn't show an image anymore

Hello i have a RCA 65’’ smart LED LCD TV 1080p SL65A55-A201083. It was working fine then it would only come on after several attempts. Now there is no picture but there is a red light on the bottom. I have tried holding the power button tried the reseting the tv with the power and volume button so far nothing works. I do have voltage at the board. Can anyone help me with this problem? This is the second site i have asked this question and no help at all. wow. Thank you for your response. I have checked those things but everything looks good. Im also not sure which board is which. Could you tell me which board is the power board and were i might be able to order it and which number would i use on the board when ordering it. Thank you so much for your help.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Hi i checked both fuses and they are good. There is 5 volts coming out of the board going to the other board. Also the other board with the hdmi rca connectors on it there is also 5 volts coming in the board and 5 volts in other places on that board. The red light stays on continuously even when you press the power button. I checked the power at the power button and it has that 2 volt continuous and when you press it it goes to zero. Hope this is helpful and here are a few more pics.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

回答がありました! View the answer 同じ問題があります

この質問は役に立ちましたか?

スコア 0
コメントを追加

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

MacBook Battery 修理キット

最低価格 $69.99

Buy Now

1回答

選択されたソリューション

@vadertaz this “then it would only come on after several attempts. Now there is no picture” sounds like a bad power board. Remove the back of your TV and take a look at all the boards. Check for obviously damaged components like leaking, domed looking capacitors etc. Post some images of your boards etc. with your question. That way we can see what you see. iFixitでの質問に画像を追加する方法

Update (12/20/2018)

Your power supply board is the one I would start with. Check the fuses for continuity and after that for power to make sure your board powers up.

Block Image

この回答は役に立ちましたか?

スコア 3

コメント:

I put some pictures of the board on my comments but i'm not sure which board is which can you advise please.

による

Your power supply board is the one I would start with. Check the fuses for continuity and after that for power to make sure your board powers up.

による

Thank you for all your help. I added some more pics and another comment.

による

Hi i put a new power board on and it is still doing the same thing. The red stand by light stays on and there is no picture or sound.There is voltage still going to the main board. I guess ill try replacing the main board. Could the small board that has the power button and volume button cause this kind of problem?

による

@vadertaz since you now already changed the power supply, go ahead and try a new mainboard. Unlikely that the error comes from the button board

による

表示する 1 他のコメントを

コメントを追加

回答を追加する

John CHAFTON さん、ありがとうございました!
統計データを表示:

過去 24時間: 0

過去 7 日: 2

過去 30 日: 23

今までの合計 105